Maya Training

Introduction to Hard Surface Modeling

Maya Training

Interiors and Furniture Vol 1 & 2 - Modeling & Cloth

Maya Training

Shading, Lighting and Rendering the Bedroom in MR

Maya Training

Robot volume one - Modeling with animation in mind

Maya Training

Spach-Alspaugh House the complete courseware

Maya Training

Burt The Cartoon Dinosaur Vol 01 - Modeling

New Maya Training

Robot Volume 02 - Hybrid Rigging
You are here > Home > SimplyMaya Community Forums
Loading

Welcome to Simply Maya

Please Sign in or Sign up for an account

Member Login

Lost your password?

Not a member yet? Sign Up!

Old 09-09-2006, 01:54 PM   #1
iron_tick
Subscriber
 
iron_tick's Avatar
 
Join Date: Sep 2002
Location: Chicagoland USA
Posts: 719
Thanks: 0
Thanked 0 Times in 0 Posts
Default Displacement map, Bump Map Problem

When i assign a bump map to my model after I set my approx node and displacement map, I get a strange result. My UV's are set correctly and ive tested my color and bump on my model before displacement so the layout appears to be fine. Feature displacement is off rendered in Maya 6 w/ Mental ray. The problem appears to occure after attaching approx node to object.
The second image is my zbrsuh render.
Attached Thumbnails
 
__________________
<html><font size=2>
<font color="blue">
And after calming me down with some orange slices and some fetal spooning,
E.T. revealed to me his singular purpose.

--TOOL, 10,000 Days---

</font></pre>
</html>
iron_tick is offline   Reply With Quote
Old 09-09-2006, 01:56 PM   #2
iron_tick
Subscriber
 
iron_tick's Avatar
 
Join Date: Sep 2002
Location: Chicagoland USA
Posts: 719
Thanks: 0
Thanked 0 Times in 0 Posts
Default

This is the same model with 1 smooth and higher displacement settings. No bump map applied and lacking detail.
Attached Thumbnails
 
__________________
<html><font size=2>
<font color="blue">
And after calming me down with some orange slices and some fetal spooning,
E.T. revealed to me his singular purpose.

--TOOL, 10,000 Days---

</font></pre>
</html>
iron_tick is offline   Reply With Quote
Old 09-09-2006, 01:58 PM   #3
iron_tick
Subscriber
 
iron_tick's Avatar
 
Join Date: Sep 2002
Location: Chicagoland USA
Posts: 719
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Again with the bump map applied and the lambert to Blinn. The Bump map was set 3 times higher than needed for this sample. Notice that it only effects certain areas of my model. It's as if the displacement isnt affecting the bump map at all.
Attached Thumbnails
 
__________________
<html><font size=2>
<font color="blue">
And after calming me down with some orange slices and some fetal spooning,
E.T. revealed to me his singular purpose.

--TOOL, 10,000 Days---

</font></pre>
</html>
iron_tick is offline   Reply With Quote
Old 09-09-2006, 02:41 PM   #4
iron_tick
Subscriber
 
iron_tick's Avatar
 
Join Date: Sep 2002
Location: Chicagoland USA
Posts: 719
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok, seems like my base model has some type of problem. Still havent pinned it down yet. Why would an OBJ file cause this to happen?
__________________
<html><font size=2>
<font color="blue">
And after calming me down with some orange slices and some fetal spooning,
E.T. revealed to me his singular purpose.

--TOOL, 10,000 Days---

</font></pre>
</html>
iron_tick is offline   Reply With Quote
Old 09-09-2006, 04:41 PM   #5
iron_tick
Subscriber
 
iron_tick's Avatar
 
Join Date: Sep 2002
Location: Chicagoland USA
Posts: 719
Thanks: 0
Thanked 0 Times in 0 Posts
Default

ok check this out. When i dont use the approx editor i get the bump to show but my displacement detail is way low.
Attached Thumbnails
 
__________________
<html><font size=2>
<font color="blue">
And after calming me down with some orange slices and some fetal spooning,
E.T. revealed to me his singular purpose.

--TOOL, 10,000 Days---

</font></pre>
</html>
iron_tick is offline   Reply With Quote
Old 09-09-2006, 05:23 PM   #6
vladimirjp
Subscriber
 
vladimirjp's Avatar
 
Join Date: Jun 2003
Location: stuck in the 90's boston, USA
Posts: 1,871
Thanks: 0
Thanked 4 Times in 3 Posts
Default

post a pic of your settings for the approx nodes.
there s 2 approx node u can use in maya.
__________________
Image dump
vladimirjp is offline   Reply With Quote
Old 09-09-2006, 08:06 PM   #7
iron_tick
Subscriber
 
iron_tick's Avatar
 
Join Date: Sep 2002
Location: Chicagoland USA
Posts: 719
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Feature displacement is off
all maps created in zbrush
All maps correctly orientated to uv direction
Attached Thumbnails
 
__________________
<html><font size=2>
<font color="blue">
And after calming me down with some orange slices and some fetal spooning,
E.T. revealed to me his singular purpose.

--TOOL, 10,000 Days---

</font></pre>
</html>
iron_tick is offline   Reply With Quote
Old 09-09-2006, 08:49 PM   #8
vladimirjp
Subscriber
 
vladimirjp's Avatar
 
Join Date: Jun 2003
Location: stuck in the 90's boston, USA
Posts: 1,871
Thanks: 0
Thanked 4 Times in 3 Posts
Default

everything looks good to me.
are you using the disp exporter to export your disp maps?

i dont usee that thing and i get pretty good results with 16bit tiffs.
simply exporting the old way.
i would also use a normal map instead of a bump map.

not much more i can help with. all seems ok from those pics.
the problem must be with Z and not maya.
chances are its the maps themselves.
__________________
Image dump
vladimirjp is offline   Reply With Quote
Old 10-09-2006, 04:33 AM   #9
iron_tick
Subscriber
 
iron_tick's Avatar
 
Join Date: Sep 2002
Location: Chicagoland USA
Posts: 719
Thanks: 0
Thanked 0 Times in 0 Posts
Default

OK, ive done a few little tests with maya and im getting the same results. made a sphere and assigned two maps. one generic pic file to displace it and a noise file to bump. All is well until i get to the approx node. Is it that simple? approx node can't handle bump maps? can anyone else reproduce this problem?
__________________
<html><font size=2>
<font color="blue">
And after calming me down with some orange slices and some fetal spooning,
E.T. revealed to me his singular purpose.

--TOOL, 10,000 Days---

</font></pre>
</html>
iron_tick is offline   Reply With Quote
Old 10-09-2006, 08:03 AM   #10
vladimirjp
Subscriber
 
vladimirjp's Avatar
 
Join Date: Jun 2003
Location: stuck in the 90's boston, USA
Posts: 1,871
Thanks: 0
Thanked 4 Times in 3 Posts
Default

u need to also convert your poly base mesh to a subD surface. yours looks like its still a cage poly.
convert it first then apply the approx nodes. try that.
__________________
Image dump
vladimirjp is offline   Reply With Quote
Old 10-09-2006, 08:25 AM   #11
iron_tick
Subscriber
 
iron_tick's Avatar
 
Join Date: Sep 2002
Location: Chicagoland USA
Posts: 719
Thanks: 0
Thanked 0 Times in 0 Posts
Default

been through that one too, no better. I even ran a script i got from zbrush site to preset my maya settings still wont work. I loaded maya on a new system, still didnt work.
__________________
<html><font size=2>
<font color="blue">
And after calming me down with some orange slices and some fetal spooning,
E.T. revealed to me his singular purpose.

--TOOL, 10,000 Days---

</font></pre>
</html>
iron_tick is offline   Reply With Quote
Old 10-09-2006, 09:00 AM   #12
iron_tick
Subscriber
 
iron_tick's Avatar
 
Join Date: Sep 2002
Location: Chicagoland USA
Posts: 719
Thanks: 0
Thanked 0 Times in 0 Posts
Default

http://www.quickdump.com/files/1942806357.html this is the disp map


http://www.quickdump.com/files/636343415.html this is the bump map

and attached is the OBJ.

I'm using Maya 6.0 let me know if you find a way.
Attached Files
File Type: zip wh.zip (110.1 KB, 12 views)
__________________
<html><font size=2>
<font color="blue">
And after calming me down with some orange slices and some fetal spooning,
E.T. revealed to me his singular purpose.

--TOOL, 10,000 Days---

</font></pre>
</html>
iron_tick is offline   Reply With Quote
Old 10-09-2006, 09:56 AM   #13
iron_tick
Subscriber
 
iron_tick's Avatar
 
Join Date: Sep 2002
Location: Chicagoland USA
Posts: 719
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Looks promising. i think it's the damn displacement map.
:angery:
__________________
<html><font size=2>
<font color="blue">
And after calming me down with some orange slices and some fetal spooning,
E.T. revealed to me his singular purpose.

--TOOL, 10,000 Days---

</font></pre>
</html>
iron_tick is offline   Reply With Quote
Old 10-09-2006, 10:54 AM   #14
vladimirjp
Subscriber
 
vladimirjp's Avatar
 
Join Date: Jun 2003
Location: stuck in the 90's boston, USA
Posts: 1,871
Thanks: 0
Thanked 4 Times in 3 Posts
Default

that site wont let me download the files.

why are they so big, u should scale them 1/2 size and rar them.
also using .map file type only benefits in cases of network rendering.
__________________
Image dump
vladimirjp is offline   Reply With Quote
Old 10-09-2006, 11:12 AM   #15
iron_tick
Subscriber
 
iron_tick's Avatar
 
Join Date: Sep 2002
Location: Chicagoland USA
Posts: 719
Thanks: 0
Thanked 0 Times in 0 Posts
Default

the .map came out better than the 32 bit tif. what type do you use for export?

better yet, if you use zbrush, what setting do you use?
__________________
<html><font size=2>
<font color="blue">
And after calming me down with some orange slices and some fetal spooning,
E.T. revealed to me his singular purpose.

--TOOL, 10,000 Days---

</font></pre>
</html>
iron_tick is offline   Reply With Quote
Reply


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem solving many dynamic objects in a pile? rohiniduggal Dynamics & Special Effects 3 14-01-2011 07:26 PM
Strange Problem - Unable to change attributes for multiple objects anthonysw3 Technical Issues 4 04-12-2010 11:56 PM

Thread Tools





A little bit about who we are
Links you might find useful
Catch up with SimplyMaya
SimplyMaya specialises in Maya tutorials. We offer over 1,000 individual Maya training videos, ranging from basic Maya tutorials through to intermediate Maya tutorials. Our tutorials are created by instructors with industry experience and are designed to get you up and running in Maya quickly without making it seem like hard work.

Copyright © 1999-2015 SimplyMaya - vBulletin® Copyright © 2000-2015, Jelsoft Enterprises Ltd.