Maya Training

Introduction to Hard Surface Modeling

Maya Training

Interiors and Furniture Vol 1 & 2 - Modeling & Cloth

Maya Training

Shading, Lighting and Rendering the Bedroom in MR

Maya Training

Robot volume one - Modeling with animation in mind

Maya Training

Spach-Alspaugh House the complete courseware

Maya Training

Burt The Cartoon Dinosaur Vol 01 - Modeling

New Maya Training

Robot Volume 02 - Hybrid Rigging
You are here > Home > SimplyMaya Community Forums
Loading

Welcome to Simply Maya

Please Sign in or Sign up for an account

Member Login

Lost your password?

Not a member yet? Sign Up!

Old 24-11-2006, 04:07 PM   #1
matthing
Subscriber
 
Join Date: Apr 2005
Location: New-Zealand
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Default can't convert to subdivisions

Hey guys,


I kan't get my model to convert to subdivision. I get this message wen I try to convert



// Error: polyToSubdiv1 (Poly To Subdiv Node): The conversion to a subdivision surface failed:
// This polygon contains an interior vertex connected by less than 3 edges.
// To fix the problem, either remove the edge with the interior vertex, or subdivide the polygon so that the interior vertex has at least 3 edges.
// The indices of the vertices in question are: 484. //


I've attached my file, so if someone is kind enough to look at it , I would really appreciate it
Attached Files
File Type: mb frank30.mb (226.0 KB, 14 views)
matthing is offline   Reply With Quote
Old 24-11-2006, 05:08 PM   #2
mustafallica
Subscriber
 
Join Date: Nov 2005
Location: calgary, alberta, canada
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Dude i have the same problem in almost all my models , hmm if u want 2 u can complete all the model then smooth it, thats what my louzy design teacher said!!
__________________
Find a job you like and you wont have to work a single day in your life
mustafallica is offline   Reply With Quote
Old 24-11-2006, 11:15 PM   #3
enhzflep
Subscriber
 
enhzflep's Avatar
 
Join Date: Oct 2006
Location: Melbourne
Posts: 313
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I've been doing the same tute today, and have come across the same error message for the first time that I recall.

Pretty easy to fix.

1) Go to Polygons->Cleanup[]
2) Reset the settings
3) Check "Nonmanifold Geometry" to on
4) Check "Faces With Zero Geometry Area" to on
5) Set Area Tolerance for zero geometry area.

I had to play with #5 for a bit. Too much and half your model dissapears. Too little, and nothing hapens. I was using something like 0.001 (default = 0.0001)

Note: Have a feeling that step 3 is unnecesary. Just so used to having to turn it on..
enhzflep is offline   Reply With Quote
Old 25-11-2006, 05:57 AM   #4
Jay
Senior Modeler - Framestore
 
Jay's Avatar
 
Join Date: Feb 2003
Location: UK
Posts: 6,234
Thanks: 39
Thanked 425 Times in 381 Posts
Default

Chances are you have some unmerged vertices.

Cheers
Jay
Jay is offline   Reply With Quote
Old 25-11-2006, 06:54 PM   #5
enhzflep
Subscriber
 
enhzflep's Avatar
 
Join Date: Oct 2006
Location: Melbourne
Posts: 313
Thanks: 0
Thanked 0 Times in 0 Posts
Default

1) Load model file
2) Polygons->Cleanup[]
3) Edit->Reset Settings
4) Toggle Other: Nonmanifold geometry to on
5) Toggle Faces with zero geometry area to on
6) Set tolerance to 0.01024
7) Hit apply
8) Toggle Faces with zero geometry to off
9) Hit apply
10) Right-mouse click frankie, and select Object Mode
11) Modify->Convert->Polygons to Subdiv

EDIT: Just saw the hand.:shakehead. I'd fogotten about this, but I had the same problem when converting the shoes. The soles just went nasty. Actually dropped the tute completely for a bit and went and did some polygon boolean modelling . Turned out, I'd forgotton to turn on Keep Faces Together in Polygons->ToolOptions->Keep Faces Together (global) or in the channel box you can set this flag for each individual extrude.

Hope this clears the frustration.
Simon

Last edited by enhzflep : 25-11-2006 at 07:01 PM.
enhzflep is offline   Reply With Quote
Old 23-12-2006, 10:39 PM   #6
marlonjohn
Subscriber
 
Join Date: Feb 2006
Posts: 1,937
Thanks: 0
Thanked 8 Times in 8 Posts
Default

i think Jay is right since ived always had this problem and just found out that there were some vertices which werent merged yet. for example if you havnt found out the problem, if you have merged an arm to the body, check all the vertices around the shoulder/armpit by click on them individualy and move them slighty to see if there is one hiding behind it(dont select because you might end up selecting the one that you may see and the one which is hidding).

marlon,
marlonjohn is offline   Reply With Quote

A little bit about who we are
Links you might find useful
Catch up with SimplyMaya
SimplyMaya specialises in Maya tutorials. We offer over 1,000 individual Maya training videos, ranging from basic Maya tutorials through to intermediate Maya tutorials. Our tutorials are created by instructors with industry experience and are designed to get you up and running in Maya quickly without making it seem like hard work.

Copyright © 1999-2015 SimplyMaya - vBulletin® Copyright © 2000-2015, Jelsoft Enterprises Ltd.