Maya Training

Introduction to Hard Surface Modeling

Maya Training

Interiors and Furniture Vol 1 & 2 - Modeling & Cloth

Maya Training

Shading, Lighting and Rendering the Bedroom in MR

Maya Training

Robot volume one - Modeling with animation in mind

Maya Training

Spach-Alspaugh House the complete courseware

Maya Training

Burt The Cartoon Dinosaur Vol 01 - Modeling

New Maya Training

Robot Volume 02 - Hybrid Rigging
You are here > Home > SimplyMaya Community Forums
Loading

Welcome to Simply Maya

Please Sign in or Sign up for an account

Member Login

Lost your password?

Not a member yet? Sign Up!

Old 29-05-2007, 07:49 PM   #1
blackstrings
Registered User
 
blackstrings's Avatar
 
Join Date: Apr 2006
Location: United Sates
Posts: 79
Thanks: 0
Thanked 0 Times in 0 Posts
Default Vector Render Help

I've done it before but not sure how come it doesn't work this time, I think I might have one small wrong tweak somewhere. The 3rd picture below is what I want to get to. But I can't seem to do so.



If i do an outline render, it gives me the First picture
If i do an Entire Mesh render it gives me the 2nd picture.
I want to get the 3rd Picture where I don't have the diagonal lines nor the empty shape like in picture 1.

I know it's probably one small tweak somewhere in my render attributes.

or maybe my default vector render is not right somewhere.

Here are my attributes under my Vector Render:

Curve tolerance: 0
Secondary curve fitting: off
Detail level: 1
Fill Object: yes
Single color: checked
Show Backface: checked
Include Edges: yes
Edge weight preset: Hairline
Edge weight: 0
Edge Style: Entire Mesh (I've tried Outline and it gives me the 1st pic)
Outlines at intersections: checked
Render Optimizationg: safe

See what i'm doing wrong, or is it that my vector render is just bugged ><

Thanks
__________________
9 months into Maya...and still learning...
0 experience with any other 3D programs
blackstrings is offline   Reply With Quote
Old 29-05-2007, 07:59 PM   #2
Perfecto
Registered User
 
Perfecto's Avatar
 
Join Date: Mar 2007
Location: TN (USA)
Posts: 1,882
Thanks: 8
Thanked 127 Times in 119 Posts
Default

Have you tried doing outline with an edge weight greater than 0. Just a thought.

If you havn't gotten an answer in the next 2 hours, I'll check it out on my computer at home.
__________________
Don't be satisfied with what you can do but rather strive to do the things you can't do!
Exceed Expectations!
Perfecto is offline   Reply With Quote
Old 29-05-2007, 09:03 PM   #3
j5ive
Subscriber
 
j5ive's Avatar
 
Join Date: Feb 2005
Location: Sunny Ol' Wigan, UK
Posts: 752
Thanks: 0
Thanked 6 Times in 6 Posts
Default

Make all edges hard on your model then try again.
__________________
If you believe in telekinesis, raise my right hand.
j5ive is offline   Reply With Quote
Old 29-05-2007, 09:14 PM   #4
Rhetoric Camel
Subscriber
 
Rhetoric Camel's Avatar
 
Join Date: Dec 2006
Location: Plattsburgh New York
Posts: 1,222
Thanks: 6
Thanked 28 Times in 23 Posts
Default

looks like someone saw the tip I posted, I wish i could help, but when I followed his steps I had no problem getting the look I was shooting for. Good luck, I've never messed with the vector renderer but it looks pretty cool
__________________
- Mike

http://rhetoriccamel.blogspot.com
Rhetoric Camel is offline   Reply With Quote
Old 29-05-2007, 09:22 PM   #5
Perfecto
Registered User
 
Perfecto's Avatar
 
Join Date: Mar 2007
Location: TN (USA)
Posts: 1,882
Thanks: 8
Thanked 127 Times in 119 Posts
Default

Okay, I made it home and tried it out. I've done it before but it's been awhile. Anyway, you need to set the min edge angle down to 1.00 (default is 90 which won't work).

Hope this helps.
Attached Thumbnails
 
__________________
Don't be satisfied with what you can do but rather strive to do the things you can't do!
Exceed Expectations!
Perfecto is offline   Reply With Quote
Old 29-05-2007, 09:23 PM   #6
blackstrings
Registered User
 
blackstrings's Avatar
 
Join Date: Apr 2006
Location: United Sates
Posts: 79
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yeah i've trired a weight bigger than 0, but it's still gives me the same thing.

But I think j5ive is correct. I have to make all my edges hard, but How do I go about doing that? especially working on my NURB surface. Can I harden edges on NURBS? or should I convert my NURBs surfaces into polly and then harden the edges?

Thanks
__________________
9 months into Maya...and still learning...
0 experience with any other 3D programs
blackstrings is offline   Reply With Quote
Old 29-05-2007, 09:29 PM   #7
blackstrings
Registered User
 
blackstrings's Avatar
 
Join Date: Apr 2006
Location: United Sates
Posts: 79
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I made the edge detail weight to 1 and even to 2, but i'm still getting some diagonals...



I want to get rid of all the diagonals.

I swear, I've done it before and it wasn't this hard LOL but yeah I'll keep trying.

Thanks
__________________
9 months into Maya...and still learning...
0 experience with any other 3D programs
blackstrings is offline   Reply With Quote
Old 29-05-2007, 09:30 PM   #8
Perfecto
Registered User
 
Perfecto's Avatar
 
Join Date: Mar 2007
Location: TN (USA)
Posts: 1,882
Thanks: 8
Thanked 127 Times in 119 Posts
Default

did you try using the settings that I just posted? Weight=0 should be fine.
__________________
Don't be satisfied with what you can do but rather strive to do the things you can't do!
Exceed Expectations!
Perfecto is offline   Reply With Quote
Old 29-05-2007, 09:34 PM   #9
blackstrings
Registered User
 
blackstrings's Avatar
 
Join Date: Apr 2006
Location: United Sates
Posts: 79
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yes I used your settings you posted, if I use just polygons then it works great for the setting.

But If i use the setting to render on my stretched/deformed Nurbs sphere, as in the image posted above, I can still see a little diagonal on the lower left of my oval sphere. but it did greatly reduced my diagnols.
__________________
9 months into Maya...and still learning...
0 experience with any other 3D programs
blackstrings is offline   Reply With Quote
Old 29-05-2007, 09:40 PM   #10
blackstrings
Registered User
 
blackstrings's Avatar
 
Join Date: Apr 2006
Location: United Sates
Posts: 79
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I think i know the problem now, maybe it's just that I deformed my sphere too much and that's why the diagonals are still showing, because I had been adding Isoparms and detaching the sphere

But when I use a fresh regular NURBs sphere, your settings works jsut fine ^^.

I just hope when i model other nurbs and deform it, the setting will works just as fine,

Thanks!
But if there any other suggestions, I will gladly try them too
__________________
9 months into Maya...and still learning...
0 experience with any other 3D programs
blackstrings is offline   Reply With Quote
Old 29-05-2007, 09:47 PM   #11
Perfecto
Registered User
 
Perfecto's Avatar
 
Join Date: Mar 2007
Location: TN (USA)
Posts: 1,882
Thanks: 8
Thanked 127 Times in 119 Posts
Default

I see what you mean. I just tried doing some deforming to both poly's and nurbs which both caused wierd things to happen to the render. Before deforming, it's perfect like you said but not after deforming. I havn't tried j5ive's suggestion yet as I'm going birthday shopping for awhile but will try later. Sorry I couldn't be of more help.
__________________
Don't be satisfied with what you can do but rather strive to do the things you can't do!
Exceed Expectations!
Perfecto is offline   Reply With Quote
Old 29-05-2007, 09:55 PM   #12
blackstrings
Registered User
 
blackstrings's Avatar
 
Join Date: Apr 2006
Location: United Sates
Posts: 79
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks man!! It was a lot of help. ^.>

I really have learned alot now that you mention the Min Edge Angle and now since I've been tweaking the Min Edge Angle for some time under the vector render. This was the effect that I wanted to know a long time ago too, but couldn't figure it out so I just forgot about it. But now that you mentioned it ^^ I can understand the vector render a little more now.

^.^
I've never really paid attention to that edge number attribute, but I see now, the number between 1 and 90 determines the detail of edges shown in the outcome render view. But yeah, when you deform the object too much, the diagonals starts showing up again.

Probbaly the best way to get rid of the diagonals is to maybe turn my NURBs into poly and harden the edges or something.
__________________
9 months into Maya...and still learning...
0 experience with any other 3D programs
blackstrings is offline   Reply With Quote

A little bit about who we are
Links you might find useful
Catch up with SimplyMaya
SimplyMaya specialises in Maya tutorials. We offer over 1,000 individual Maya training videos, ranging from basic Maya tutorials through to intermediate Maya tutorials. Our tutorials are created by instructors with industry experience and are designed to get you up and running in Maya quickly without making it seem like hard work.

Copyright © 1999-2015 SimplyMaya - vBulletin® Copyright © 2000-2015, Jelsoft Enterprises Ltd.