Maya Training

Introduction to Hard Surface Modeling

Maya Training

Interiors and Furniture Vol 1 & 2 - Modeling & Cloth

Maya Training

Shading, Lighting and Rendering the Bedroom in MR

Maya Training

Robot volume one - Modeling with animation in mind

Maya Training

Spach-Alspaugh House the complete courseware

Maya Training

Burt The Cartoon Dinosaur Vol 01 - Modeling

New Maya Training

Robot Volume 02 - Hybrid Rigging
You are here > Home > SimplyMaya Community Forums
Loading

Welcome to Simply Maya

Please Sign in or Sign up for an account

Member Login

Lost your password?

Not a member yet? Sign Up!

Old 29-10-2010, 06:17 PM   #1
moosenoodles
Subscriber
 
Join Date: Apr 2006
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Default Mata 2011: Extrude Along Curve randomness

Hi me again

I am still plodding through 2011 seeing whats what and I think this horrible RMB mode selection or top menu 'select face' mess of an idea is causing me more strange happenings, but again its all random one min its fine next its not. Look at my extrude along a curve here.

I did various faucet's and other pipework fine, I go do some grill creation piping and I get it snapping back on itself, there are no snap locks going on its all as it was last time I fired it up and did an extrusion along curve, which was all fine with same settings..

Usually ive only seen this when you dont specify enough divisions and u ramp them up in the older clients and things sit pretty then but this time thats not doing the job.

Maya 2011 is certainly giving me a fight

There will be a whole forum full of my Maya 2011 woes I can see it but hey it might help others when searching for same problems..

I tried it with the full set of faces as well, the image shows the last attempt just trying inner faces.


moosenoodles is offline   Reply With Quote
Old 29-10-2010, 07:17 PM   #2
ctbram
Moderator
 
ctbram's Avatar
 
Join Date: Jan 2004
Location: Michigan, USA
Posts: 2,995
Thanks: 42
Thanked 582 Times in 532 Posts
Default

Please describe exactly what you did. I have played with extrude and cannot duplicate what you have above?

For instance I create a poly cyinder, then select all the faces around the side, then extrude those faces out, then create a cv curve from the side view, then select the top face and the cv curve and right mouse select extrude.

Then in the channel box I adjust the number of divisions until I get a clean extrude. This seems to always work for me.

Also, sometimes it's a good idea to rebuild the cv curve uniformly, adding cv's as needed to get a even distribution of cv's and then delete history before doing the extrude.
__________________
"If I have seen further it is by standing on the shoulders of giants." Sir Isaac Newton, 1675

Last edited by ctbram : 29-10-2010 at 07:22 PM.
ctbram is offline   Reply With Quote
Old 29-10-2010, 08:14 PM   #3
moosenoodles
Subscriber
 
Join Date: Apr 2006
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Default

hiya,

Well ive been doing it as I have done in older Maya versions,

Make a cv curve and rebuild it line it up where i want and make sure the shape is accurate for me.

Make a cylinder with some height to it.

Select curve first

Shift select cylinder

Then put the cylinder into face mode, here in Maya 2011 this makes the curve turn "green" grrrr, anyhow u get around that with shift selecting the first face and then the rest of them you need which turns the curve back to its former white selection.

Open extrude box, reset tool, select amount of divisions and hit apply.

Ive removed the faces and left over rubish on that one I had that issue with and tidied it up, its fine now but the whole process should of been done again in a much more faster manner

So thats how I have always done this execution but some reason there seems to be some oddness with the cylinder I am guessing with its size or how many faces maybe etc etc, this though is only a problem for me in Maya 2011..

Again take it as a pinch of salt, im getting older and I do have alot on at home right now so could be user error

Cheers,

James.

p.s the RMB options for selection seem to be very odd in 2011 in my other thread this was mentioned by another how its a bit weird with its back and forth to object mode regarding F8!!..

Prob just need to get my head around some changes here I dunno?
moosenoodles is offline   Reply With Quote
Old 29-10-2010, 08:32 PM   #4
daverave
The thin red line
 
daverave's Avatar
 
Join Date: Aug 2009
Location: England
Posts: 4,471
Thanks: 101
Thanked 952 Times in 879 Posts
Default

The only thing I do differant to ctbram is I snap the first CV point to the central vert then go into side or front to do the rest, save some time linning them up............dave
__________________


Avatar Challenge Winner 2010
daverave is offline   Reply With Quote
Old 29-10-2010, 08:36 PM   #5
moosenoodles
Subscriber
 
Join Date: Apr 2006
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have the snapping addiction also

Its just this wasnt that critical its not even in close view so eyeball was enough..

Im guessing your both using Maya 2011?

I will do some more extrude poly faces along a curve bit later here and see how they go, but just niggles me when its working one min then same procedure dont work the next time using same items..

blegh!

At least last problem was the B key being hit with soft selection, this time Im sure ive done nothing wrong with fumbling fingers
moosenoodles is offline   Reply With Quote
Old 29-10-2010, 10:29 PM   #6
daverave
The thin red line
 
daverave's Avatar
 
Join Date: Aug 2009
Location: England
Posts: 4,471
Thanks: 101
Thanked 952 Times in 879 Posts
Default

Sorry I use 2009 as far as I know none of the modelling tools have changed that much, more has been done in dynamics..........dave
__________________


Avatar Challenge Winner 2010
daverave is offline   Reply With Quote
Old 30-10-2010, 01:54 PM   #7
ctbram
Moderator
 
ctbram's Avatar
 
Join Date: Jan 2004
Location: Michigan, USA
Posts: 2,995
Thanks: 42
Thanked 582 Times in 532 Posts
Default

I am using 2011 but what Dave said is correct from a modeling point of view practically nothing has changed.

I personally do not care for the black on darker black on even darker black of maya 2011. It is making me go blind.

Most people do not have their monitors color calibrated correctly and have the gamma set way to high. I have my monitor calibrated and the 2011 UI is TOO DARK!

Go to the attributes panel and look at the upstream downstream node arrows! On my monitor they are practically invisible! I much prefer the old lighter interface.

But I also prefer to have the latest version just in case someday, probably when butterflies come out my butt, autodesk will bring the modeling tool set out of the 1960's.
__________________
"If I have seen further it is by standing on the shoulders of giants." Sir Isaac Newton, 1675
ctbram is offline   Reply With Quote
Old 03-12-2010, 03:48 AM   #8
GhosTz
Registered User
 
GhosTz's Avatar
 
Join Date: Jun 2006
Location: BC, Canada
Posts: 82
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Sounds like you fixed it, but for future reference:
That happens when you extrude from the end of the curve instead of the start.

An easy solution is to select the curve, then shift-rightclick on Reverse Curve.
GhosTz is offline   Reply With Quote
Old 03-12-2010, 05:34 AM   #9
bullet1968
Lifetime Member
 
bullet1968's Avatar
 
Join Date: Feb 2010
Location: Australia
Posts: 4,255
Thanks: 158
Thanked 651 Times in 621 Posts
Default

Ok I replicated it....Ghost you were correct...when I moved the cylinder the the end of the polyline and not the start it pinged back on itself...see if that is the cause moose....otherwise yeh just reverse the polyline.

cheers bullet
__________________
bullet1968

"A Darkness at Sethanon", a book I aspire to model some of the charcters and scenes
bullet1968 is offline   Reply With Quote
Reply


Similar Threads
Thread Thread Starter Forum Replies Last Post
Extrude Manipulator does not appear Celebrus Technical Issues 11 15-10-2013 09:37 PM
LayoutTools for Maya 2011 is here... ctbram Members Lounge 1 06-12-2010 11:32 PM
Open a Lightwave file in Maya 2011 radiant777 Maya Basics & Newbie Lounge 2 04-12-2010 03:45 AM

Thread Tools





A little bit about who we are
Links you might find useful
Catch up with SimplyMaya
SimplyMaya specialises in Maya tutorials. We offer over 1,000 individual Maya training videos, ranging from basic Maya tutorials through to intermediate Maya tutorials. Our tutorials are created by instructors with industry experience and are designed to get you up and running in Maya quickly without making it seem like hard work.

Copyright © 1999-2015 SimplyMaya - vBulletin® Copyright © 2000-2015, Jelsoft Enterprises Ltd.