Maya Training

Introduction to Hard Surface Modeling

Maya Training

Interiors and Furniture Vol 1 & 2 - Modeling & Cloth

Maya Training

Shading, Lighting and Rendering the Bedroom in MR

Maya Training

Robot volume one - Modeling with animation in mind

Maya Training

Spach-Alspaugh House the complete courseware

Maya Training

Burt The Cartoon Dinosaur Vol 01 - Modeling

New Maya Training

Robot Volume 02 - Hybrid Rigging
You are here > Home > SimplyMaya Community Forums
Loading

Welcome to Simply Maya

Please Sign in or Sign up for an account

Member Login

Lost your password?

Not a member yet? Sign Up!

Old 24-01-2008, 03:52 AM   #1
the_renans
Registered User
 
Join Date: Dec 2005
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default blobby surface dissapear on refraction

i don´t know why, but the blobby surface particles dissapear when i put them inside or behind a material with refraction. It happens in mental ray and maya software.

I used diferent materials, but same happens.

This is not a raytrace problem, since i put the maximum atributtes in render settings!

when i change the type of the particles to sphere they work normal.

Does anybody have an idea of what is going wrong ?!
Attached Thumbnails
 
the_renans is offline   Reply With Quote
Old 24-01-2008, 05:07 AM   #2
ragecgi
Super Moderator
 
ragecgi's Avatar
 
Join Date: Sep 2002
Location: Minnesota, USA
Posts: 3,709
Thanks: 0
Thanked 13 Times in 12 Posts
Default

Hmm, I checked the docs, and it looks like even though you have the settings maxed, you MIGHT be getting limited.

Don't quote me on that, BUT, here is a snippet from what I've found:

Getting Started with Maya
> Rendering
> Lesson 5: Caustics

Adjusting the refraction levels

When the refraction levels are set too low, light rays do not refract through all of the surfaces enough to provide a realistic indication of a translucent surface when raytraced. This results in the object appearing opaque when it should appear translucent.

Increasing the Refractions setting allows the renderer to calculate what is seen through the surfaces of the glass by allowing the light rays to refract the correct number of times.

In the next step, you change the Refraction settings so that the bottle will appear translucent when rendered.
To increase the refraction levels

1. In the Render Settings window, select the mental ray tab and then open the Raytracing attributes.
2. In the Raytracing section set the following:
* Refractions: 6
* Max trace depth: 8

The Refractions setting sets the number of times a light ray can be refracted. When the setting is too low the ray does not penetrate through all of the surfaces. The Max Trace Depth setting limits the total Refraction and Reflection settings. By setting it to 8, you ensure that two reflection and six refraction calculations can occur.

Photons refract in a manner similar to light rays when rendering. Increasing the Refractions setting for the Caustic Photons ensures that the renderer can correctly calculate the caustics that should occur with the bottle. In this case, matching the Caustic Photon refraction settings with the Raytracing refractions is a good practice.
To increase the photon refraction settings

1. In the Render Settings window, select the mental ray tab and open the Caustics and Global Illumination section.
2. In the Photon Tracing section set the following:
* Max Photon Depth: 6
* Photon Refractions: 6

...ignore me if I'm totaly off base
__________________
Israel "Izzy" Long
Motion and Title Design for Broadcast-Film-DS
izzylong.com
ragecgi is offline   Reply With Quote
Old 24-01-2008, 06:14 AM   #3
NeoStrider
Registered User
 
NeoStrider's Avatar
 
Join Date: Jun 2004
Location: Cleveland, Ohio (USA)
Posts: 1,541
Thanks: 0
Thanked 2 Times in 2 Posts
Default

there's also the possibility that the refraction is causing the particles not to be seen because of the strange shape and thickness of the object... it might not actually show any of the particles because through refraction you might be looking at an entirely different area than straight through the object. you'd know if this was the case if you changed the index of refraction value to closer to air or vacuum (1.000). if you change the IOR to that value, you should be able to see through to the particles, but the higher that value goes, the more distortion (or the less particles) you'll see.

that's my take on it.
__________________
Accept no substitutions.
NeoStrider is offline   Reply With Quote
Old 24-01-2008, 08:50 AM   #4
mirek03
Subscriber
 
mirek03's Avatar
 
Join Date: Feb 2006
Location: Australia
Posts: 2,752
Thanks: 0
Thanked 3 Times in 3 Posts
Default

visible in refractions and reflections is turned off by default for particles.., check the render settings , i forget the nodes name but it has

cast shadows
receive shadows
visible in reflections
visible in refractions
ect


not render globals.., in the AE
you know the place.., see if 'visible in refractions' is checked.
__________________
take it easy and life will be easy
mirek03 is offline   Reply With Quote
Old 24-01-2008, 02:44 PM   #5
the_renans
Registered User
 
Join Date: Dec 2005
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hey mirek03, you was right !
The blobby surface has the visible in refraction and reflection turned off for default.
It works fine.

I did not try the other answers, but Thanks for everybody.

Now i would like the particles to appear but not be refracted into the surface. Is it possible ?!

The scene is a coke pouring and the particles will be the bubbles. I used real flow with a script that change the liquid to foam when it collides. Exported the liquid as mesh and bubbles as particles. Now i'm trying to render this. The liquid i used dielectric material and for the bubbles i will use the blobby surface.

Thanks
the_renans is offline   Reply With Quote
Old 24-01-2008, 08:08 PM   #6
ragecgi
Super Moderator
 
ragecgi's Avatar
 
Join Date: Sep 2002
Location: Minnesota, USA
Posts: 3,709
Thanks: 0
Thanked 13 Times in 12 Posts
Default

Originally posted by the_renans
Now i would like the particles to appear but not be refracted into the surface. Is it possible ?!
Render those as a separate pass, and comp them in post

And by the way, good job mirek03 catching that
__________________
Israel "Izzy" Long
Motion and Title Design for Broadcast-Film-DS
izzylong.com
ragecgi is offline   Reply With Quote
Old 24-01-2008, 08:21 PM   #7
the_renans
Registered User
 
Join Date: Dec 2005
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default

The problem is that i don´t know how to do that!
Do you know any tutorial on render layers/render passes ?!!
the_renans is offline   Reply With Quote
Old 24-01-2008, 08:43 PM   #8
ragecgi
Super Moderator
 
ragecgi's Avatar
 
Join Date: Sep 2002
Location: Minnesota, USA
Posts: 3,709
Thanks: 0
Thanked 13 Times in 12 Posts
Default

Interesting that you asked that

http://forum.simplymaya.com/showthre...s+pass+control

Also, closer to the bottom of that thread is a video made by Alias (then) that better explains the newer features too
__________________
Israel "Izzy" Long
Motion and Title Design for Broadcast-Film-DS
izzylong.com
ragecgi is offline   Reply With Quote
Old 25-01-2008, 12:17 AM   #9
mirek03
Subscriber
 
mirek03's Avatar
 
Join Date: Feb 2006
Location: Australia
Posts: 2,752
Thanks: 0
Thanked 3 Times in 3 Posts
Default

thanks.., it was a coincidence i watched a tut on blobby surfaces the day before .., thought it something to keep in my personal RAM
__________________
take it easy and life will be easy
mirek03 is offline   Reply With Quote

A little bit about who we are
Links you might find useful
Catch up with SimplyMaya
SimplyMaya specialises in Maya tutorials. We offer over 1,000 individual Maya training videos, ranging from basic Maya tutorials through to intermediate Maya tutorials. Our tutorials are created by instructors with industry experience and are designed to get you up and running in Maya quickly without making it seem like hard work.

Copyright © 1999-2015 SimplyMaya - vBulletin® Copyright © 2000-2015, Jelsoft Enterprises Ltd.