Maya Training

Introduction to Hard Surface Modeling

Maya Training

Interiors and Furniture Vol 1 & 2 - Modeling & Cloth

Maya Training

Shading, Lighting and Rendering the Bedroom in MR

Maya Training

Robot volume one - Modeling with animation in mind

Maya Training

Spach-Alspaugh House the complete courseware

Maya Training

Burt The Cartoon Dinosaur Vol 01 - Modeling

New Maya Training

Robot Volume 02 - Hybrid Rigging
You are here > Home > SimplyMaya Community Forums
Loading

Welcome to Simply Maya

Please Sign in or Sign up for an account

Member Login

Lost your password?

Not a member yet? Sign Up!

Old 09-08-2008, 01:11 PM   #1
Tristanartform
Registered User
 
Join Date: Mar 2007
Posts: 92
Thanks: 0
Thanked 0 Times in 0 Posts
Default Face won't extrude along curve

Maya 8.5, running on a Precision 690, 2 Gig RAM, OS: Windows XP Pro

Hello. I am trying to extrude a polygon face along a curve which is snapped to the face center. The face is from a simple cube created for just this action.

I select the face, select the curve, click extrude with the box checked for "use selected curve for extrusion". The face offsets without following the curve. If I increase divisions in the attributes editor it begins to move along the curve but not all the way to the end point.

before it finishes following the curve, the extrusion twists and arcs back to the starting point of the curve where it touches the extruded face.

How far along the selected curve the extrusion follows before it twists and circles back is relative to the number of divisions I select. More divisions, the further along the curve it goes. However I have given it 400 divisions just to see what happens -- it still doesn't make it all the way to the end of the curve, which has but 14 spans.

I hope I have explained this well enough to describe the problem. Anyone with any ideas as to why this isn't working properly, I'd appreciate the help.

Thank you.

Tristan
Tristanartform is offline   Reply With Quote
Old 09-08-2008, 02:42 PM   #2
arran
Registered User
 
arran's Avatar
 
Join Date: Dec 2005
Location: Brooklyn, NY
Posts: 3,708
Thanks: 0
Thanked 9 Times in 9 Posts
Default

i think you just need to reverse the direction of the curve and then try it again.
__________________
arran3D

arran3D blog
arran is offline   Reply With Quote
Old 09-08-2008, 02:46 PM   #3
Tristanartform
Registered User
 
Join Date: Mar 2007
Posts: 92
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi. I should have said that I had already tried that.

Also tried rebuilding the curve, both linear and cubic. No change.

Anyone know what's going on?

Tristan
Tristanartform is offline   Reply With Quote
Old 09-08-2008, 04:37 PM   #4
arran
Registered User
 
arran's Avatar
 
Join Date: Dec 2005
Location: Brooklyn, NY
Posts: 3,708
Thanks: 0
Thanked 9 Times in 9 Posts
Default

to be honest, it still sounds like a problem with the curve direction. post up a picture so we can the problem. you could also try reversing the normals on the polygon (though i doubt that will do anything) and also playing with the first few extrude options in the history.
__________________
arran3D

arran3D blog
arran is offline   Reply With Quote
Reply


Similar Threads
Thread Thread Starter Forum Replies Last Post
Extrude Manipulator does not appear Celebrus Technical Issues 11 15-10-2013 09:37 PM

Thread Tools





A little bit about who we are
Links you might find useful
Catch up with SimplyMaya
SimplyMaya specialises in Maya tutorials. We offer over 1,000 individual Maya training videos, ranging from basic Maya tutorials through to intermediate Maya tutorials. Our tutorials are created by instructors with industry experience and are designed to get you up and running in Maya quickly without making it seem like hard work.

Copyright © 1999-2015 SimplyMaya - vBulletin® Copyright © 2000-2015, Jelsoft Enterprises Ltd.