Maya Training

Introduction to Hard Surface Modeling

Maya Training

Interiors and Furniture Vol 1 & 2 - Modeling & Cloth

Maya Training

Shading, Lighting and Rendering the Bedroom in MR

Maya Training

Robot volume one - Modeling with animation in mind

Maya Training

Spach-Alspaugh House the complete courseware

Maya Training

Burt The Cartoon Dinosaur Vol 01 - Modeling

New Maya Training

Robot Volume 02 - Hybrid Rigging
You are here > Home > SimplyMaya Community Forums
Loading

Welcome to Simply Maya

Please Sign in or Sign up for an account

Member Login

Lost your password?

Not a member yet? Sign Up!

Old 24-07-2010, 08:40 AM   #1
rose777
Registered User
 
Join Date: Jul 2010
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default How do I select only the upper vertices of a complex object?

How do I select only the upper vertices of a complex object?

Meaning when I select the vertices I need in top view, Maya 11 will select all vertices, i.e. also the ones beneath that I do not see...how can I limit the selection to the vertices I see only?
rose777 is offline   Reply With Quote
Old 24-07-2010, 12:30 PM   #2
Chirone
Subscriber
 
Chirone's Avatar
 
Join Date: Dec 2007
Location: NZ
Posts: 3,124
Thanks: 11
Thanked 147 Times in 143 Posts
Default

with your selection tool go into the tool settings and check 'camera based selection'

i assume the placements for the tool settings button option is the same as it seems to always has been, it's the middle button on the top right corner (the three buttons show the attribute editor, tool settings, and channel box)
__________________


that's a "Ch" pronounced as a "K"

Computer skills I should have:
Objective C, C#, Java, MEL. Python, C++, XML, JavaScript, XSLT, HTML, SQL, CSS, FXScript, Clips, SOAR, ActionScript, OpenGL, DirectX
Maya, XSI, Photoshop, AfterEffects, Motion, Illustrator, Flash, Swift3D
Chirone is offline   Reply With Quote
Old 24-07-2010, 05:53 PM   #3
3ddon
Registered User
 
Join Date: May 2009
Posts: 153
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Originally posted by Chirone
with your selection tool go into the tool settings and check 'camera based selection'
I didn't find the settings...

---------------------------------------------------------------
try back face culling,it annoyed me so many times...
3ddon is offline   Reply With Quote
Old 24-07-2010, 06:07 PM   #4
Perfecto
Registered User
 
Perfecto's Avatar
 
Join Date: Mar 2007
Location: TN (USA)
Posts: 1,882
Thanks: 8
Thanked 127 Times in 119 Posts
Default

You can get to the settings simply by double clicking the move tool in the tool box. Or, you can get to the settings by Modify>Transformation Tools>Move Tool Options box...or rotate tools options box, etc.

Here's a screenshot of the Move Tool Settings.
Attached Thumbnails
 
__________________
Don't be satisfied with what you can do but rather strive to do the things you can't do!
Exceed Expectations!
Perfecto is offline   Reply With Quote
Old 24-07-2010, 10:22 PM   #5
3ddon
Registered User
 
Join Date: May 2009
Posts: 153
Thanks: 0
Thanked 0 Times in 0 Posts
Default

thanks Perfecto,
but how it works?
when I checked that option nothing will selected.
3ddon is offline   Reply With Quote
Old 24-07-2010, 11:16 PM   #6
Perfecto
Registered User
 
Perfecto's Avatar
 
Join Date: Mar 2007
Location: TN (USA)
Posts: 1,882
Thanks: 8
Thanked 127 Times in 119 Posts
Default

select an Sphere, activate the move tool, change tool setting to Camera Based Selection. Then go into...lets say...a top view. Marquee drag around all the vertices. If you go back into a side view..you'll see that only the top half of the vertices were selected. Because the camera from a top view could not see the vertices on the lower half.

edit: Also, if you are in a perspective view, marquee drag around all the vertices, then rotate your camera. You'll see that the vertices on the other side were not selected.
__________________
Don't be satisfied with what you can do but rather strive to do the things you can't do!
Exceed Expectations!
Perfecto is offline   Reply With Quote
Old 24-07-2010, 11:22 PM   #7
Perfecto
Registered User
 
Perfecto's Avatar
 
Join Date: Mar 2007
Location: TN (USA)
Posts: 1,882
Thanks: 8
Thanked 127 Times in 119 Posts
Default

I think I understand what you are wanting.

Forget the camera based selection.


Just turn on Backface Culling.

If Backface Culling is grayed out (not selectable) turn on smooth shade. That should allow you to select backface culling.

That will prevent you from selecting faces, verts, etc on the opposite side of your mesh.
Attached Thumbnails
 
__________________
Don't be satisfied with what you can do but rather strive to do the things you can't do!
Exceed Expectations!
Perfecto is offline   Reply With Quote
Old 25-07-2010, 12:05 AM   #8
3ddon
Registered User
 
Join Date: May 2009
Posts: 153
Thanks: 0
Thanked 0 Times in 0 Posts
Default

thaanks perfecto for your brief explanation,

I know back face culling,but it annoying me some times.

I understood about 'camera based selection',
but its not working as you said in my system,I'll try it in my institute.
3ddon is offline   Reply With Quote
Old 25-07-2010, 03:13 PM   #9
maheshsubbiah
Registered User
 
maheshsubbiah's Avatar
 
Join Date: Mar 2009
Location: India
Posts: 145
Thanks: 2
Thanked 21 Times in 19 Posts
Default

I think the best option will be to go to vertex mode and then use paint selection tool to select all the vertices u need.
maheshsubbiah is offline   Reply With Quote

A little bit about who we are
Links you might find useful
Catch up with SimplyMaya
SimplyMaya specialises in Maya tutorials. We offer over 1,000 individual Maya training videos, ranging from basic Maya tutorials through to intermediate Maya tutorials. Our tutorials are created by instructors with industry experience and are designed to get you up and running in Maya quickly without making it seem like hard work.

Copyright © 1999-2015 SimplyMaya - vBulletin® Copyright © 2000-2015, Jelsoft Enterprises Ltd.