Simply Maya User Community

Simply Maya User Community (
-   Lighting & Rendering (
-   -   Maya software renders are very grainy (

xgabrielx 11-10-2020 05:21 PM

Maya software renders are very grainy
2 Attachment(s)
Several years ago, I made an intro for my videos, that was kinda based on the 20th century fox intro. This was in Maya 2008, I think. Anyway, I decided to update it a little. I originally just used a bunch of Lamberts to give it a flat, cartoonish look like the 20th century fox searchlights intro, but decided to add some more detail, and use images to create textures - something I've done many times.
But the renders are very grainy (see attached images). I tried turning up samples in render options, but that did nothing (also...isn't that just antialiasing?) Also, the textures look fine as the render is underway. All the grain and noise just appears when the render is done, so it seems like an added effect? If so, I don't remember adding it.
I'm rendering with Maya software. If I remember, Mental ray disappeared as an option...I think when I added a depth of field effect to the camera. But I get the same grain with the default cameras, too.
If I just use the light that represents the sun, everything looks fine, but the shadows are impenetrable, so I want to use a fill light, with shadows turned off, and more of a blue tint, to represent light scattered by the sky and cast some light into the shadows.
But I have to turn the light way down, or it's too much. What I'm currently trying is making the textures darker in photoshop, so I can turn up the lights. It seems to be working, but I never had this issue in Maya before.
I don't like that the grain isn't there, and then appears at the end of the render. Cus that kinda rules out most of the things I suspected as the cause.
Also: I may have posted this twice. I don't know. I don't see it from when I tried before an hour or so ago, so maybe I messed up and posted it incorrectly. If it's just a held-for-review thing, I'd prefer if the other one was deleted cus this one has more details. But I never saw any message, so I think it just timed out cus I never sent it. Or I hit "Preview post" and then forgot I hadn't submitted the message.
Anyway, here are some pics:

xgabrielx 14-10-2020 06:02 PM

Not sure what's going on. I tried going back to Maya 2010, which the file was created on, but now I can't even open it, because I've re-saved it in Maya 2016. I can open the original copy - the one I wanted to update - but I'd spent ages making UV maps and stuff and adding stuff to the scene.
At least, in Maya 2010, the scene is fine. No noise problem.
I tried opening it in Maya 2019 and got a warning about missing Mental Ray nodes, which is kinda odd. And I never got that message in Maya 2016, even though that doesn't have Mental Ray, either. I gues just the message is new.
So I guess what happened was related to Mental ray somehow? I did play with it in the old version. All I did was try some Mental Ray renders with global illumination and final gather. It looked great, but I think the render time was off-putting back then. I guess I changed the photons slider on a light or two, but I dunno if I did or not.
But as far as I know, everything in the scene now is fresh.
The scene wasn't fresh in my memory, so I went through a process of opening the old scene, deleting everything except, for example, the ground plane, copying that, then pasting it into a new scene. I did that with everything in the scene. Mostly so I could go through everything on the outliner, one thing at a time, examining everything. I was UV mapping as I went. I just made new lights, rather than import.
Right now, I'm not sure what to do. Is there a way to save a scene in 2016 so it can be read by 2010? As far as I know, I've not used any new features
I could also be totally wrong about the cause of the noise, but the only way I can think of to check, is to open the recent copy of the file in the older version of Maya

xgabrielx 31-10-2020 07:34 PM

Okay, so I rolled back to Maya 2010 for this scene and the grraininess went away. I had a ton of issues because all the saved versions I had had been resaved in later versions so I had some issues.. Even after I fixed those, renders would occasionally lock up and freeze, and batch renders would only do one frame. I noticed that it only happens when a certain area within the scene is visible in the render.
I did a bunch of troubleshooting by deleting one object at a time, and by rendering different views, trying to find the troublesome objects, but it seemed to be more of a cumulative thing. It's progressing nicely in a batch render now. At first, I could only get through a few frames, so...I SUSPECT, the problem has something to do with the fact that my CPU (Ryzen 3600) seems to be overclocked a little (4Ghz), but the V-core looks to be stock. Think I'll reset factory defaults and try again. Or maybe bump up the voltage a little. I guess at some point, I may have half-aXXXd a stress test.
First, I'll see if this render completes. If not, I'll remove the overclock and restore the deleted geometry and textures.

xgabrielx 01-11-2020 03:32 PM

Well....not the overclock. But still renders just randomly lock up.. No warning, no error notification. It seems as though certain parts of the scene are far more regular offenders than others, and any frame that fails to render, can be tried again and will either fail at a different point, or maybe even complete...all of which made me think it's a hardware problem. BUT, there is an ocean in the scene, and a boat. Neither of which are even in view at the worst places for crashes.
But it's at least a mechanism by which the same exact view of the same frame from the same camera, can behave differently on multiple renders. It doesn't appear to be cached (the ocean and boat) it seems like a more or less random simulation every time. Is there a way to cache that? I tried making a geometry cache, but isn't that just for deformations of the mesh itself? I remember caching physics simulations with rigid bodies, but that's going way back. I guess all I can do for now, is keep saving versions with different stuff deleted

xgabrielx 06-11-2020 02:55 PM

Okay, well, I got that fixed So...rolling back to an earlier version of Maya was not the play. I have no idea why Maya 2010 was crashing, so I decided to try again in Maya 2019. The crashes were infuriating and time-wasting, so better to attack the issue of the grainy renders.
Anyways, I decided to try again at eliminating all the Mental Ray nodes, but this time, instead of trying to identify them in the outliner, I used the MEL command:
unknownPlugin -remove "Mayatomr";
The renders SEEM fine now. I haven't checked fully cus I'm currently on a batch render at low quality, to see if it can complete. I think it will, because batch renders ALWAYS stalled on frame 41 before, and it's on 61 right now
Once it's complete, I'll do a high quality render in an area I know had bad grain.
So...yeah.. I have no idea what was causing the crashing, but...problem solved. Hopefully my question helps someone else who has the same problem, so if there's an "issue resolved" sticker or whatever, pop it on here!

xgabrielx 06-11-2020 03:13 PM

Nevermind. We're stalled on Frame 61. All cores are at 100% (another odd thing. When a batch render stalls, all cores are at 100%, but when I just try to render a frame in the render window, and it stalls, only 2 cores are at 100% and the rest go idle)
Is there a known issue with Maya and Ryzen 3000 series CPUs? I don't see why there would be in Maya 2019

xgabrielx 08-11-2020 02:17 PM

Okay, NOW it's fixed. I dunno how much use this thread will be to anyone, since it was about the grainy textures issue, which was simply fixed by deleting all the mental ray nodes. The problem with renders I finally tracked down by deleting objects one at a time. pPipe4, it turns out, was the culprit. A polygon pipe that existed in the outliner, but not in the scene. Once I deleted that, everything worked fine. Not only that, the frames that didn't crash before, now render much faster. I guess deleting the Mental ray nodes caused that particular piece of geometry to be screwy some way that never triggered any warning.

So there ya go. Two problems solved. Hopefully someone with the exact same problem/(s) stumbles on this thread

All times are GMT. The time now is 02:33 PM.

Powered by vBulletin® Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Simply Maya 2018