Simply Maya User Community

Simply Maya User Community (
-   Work In Progress (
-   -   Urgent Help (

MrPinkus 13-05-2017 05:04 AM

Urgent Help
2 Attachment(s)
Hi Guys, can anyone shed some light on what is happening with the normals/normal map on my model below?

The fist image has major artifact issue and doesn't have smooth mesh preview. The second has smooth mesh preview and no artifacts.

The base model is quite high in polygons for a game asset so there is not issue with a lack of GEO. I have never come across this before any help?


Martel 14-05-2017 04:11 PM

Difficult to say when I don't have the model in Maya in front of me but I think it has something to do with your UV's and not your normal map. I had something similair last week when I had a good looking UV map but in the viewport everything was totally messed up. I solved the issue by redoing the UV's. It was a simple object so it was easy enough with some automatic mapping. It could be that you have the same problem.

Another option is to duplicate the mesh and delete the Original. I have had numerous occassions where Maya completely messes up and by just duplicating the mesh the problem was solved.

But like I said I can't rely tell from just those 2 images what's going on. You could try my 2 suggestions. If that doesn't work you could send it to me and can take a look

Kurt 15-05-2017 01:06 AM

First glance it looks like flipped normal's or uvs. You can try try conforming your normal's. Ive had a few issues like that and it was either uv's on top of each other or green channel in the normal map. Martel has good suggestions as well.

MrPinkus 15-05-2017 11:17 AM

Thanks Guys, the winner is Kurt! For some reason that makes no sense, the normals had flipped over but only on random faces not the entire model so with some careful selection I was able to reverse the individual faces to keep the normal map clean without smooth mesh.

Thanks for taking the time, it is much appreciated.


Kurt 15-05-2017 02:31 PM

Ya the newer version of Maya seem to do that a lot, not sure if its a bug or not. Glad you figured it out.

All times are GMT. The time now is 07:04 PM.

Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Simply Maya 2018