SimplyMaya Forums

Welcome to the forum, feel free to ask questions here.

Home / forum / Animation / Animation / Help problem with Walk Cycle...
Register FAQ Members List Calendar Mark Forums Read

New Thread
 
Thread Tools
Old 08-03-2004, 11:20 AM   #1
siawyuan
Subscriber
 
Join Date: Feb 2004
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Question Help problem with Walk Cycle...

i try "The Walk Cycle" tutorial by Kurt Boutilier, but when i want to animate the chracter the problem occur.
when i try to move its L_Leg the all body follow, additional when i pull the root down also the same problem. such as don't have the floor for the chracter to step on it.
siawyuan is offline   Reply With Quote
Old 08-03-2004, 02:49 PM   #2
Kurt
Registered User
 
Kurt's Avatar
 
Join Date: May 2002
Location: Niagara Falls, Canada
Posts: 5,298
Thanks: 0
Thanked 64 Times in 64 Posts
Default

Sounds like your Ik's are not sticky..... select all the Ik handels on the foot > open the attribute editor> open IK handle Attributes> find stickiness> make sure it has sticky selected.

Also make sure you are selecting the ROOT handel for moving his body forward and the UPDOWN handel for moving up and down. The handel called SKELLY is for flipping all the model around and upside down.

That sticky option was added in Maya 5, and the model was done in maya 4.5... its a pain but thats how you fix it.

As far as the body moving forward their is a expression on the foot control... If you dont want the body to stay centered as you move one of the feet... select one of the feet and in the channel box you will see OUTPUTS..... find "center pelvis" and switch it to HAS NO EFFECT from normal. That will stop his body centering over his feet. You will have to manually move his root to center when you go to animate wiht that option off.



Let me know if that did the trick.

Kurt
__________________
I am enough of an artist to draw freely upon my imagination, knowledge is limited, imagination encircles the world. (Albert Einstein)

http://kurtboutilier.cgsociety.org/
Kurt is offline   Reply With Quote
Old 08-03-2004, 04:30 PM   #3
siawyuan
Subscriber
 
Join Date: Feb 2004
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Default

body moving is ok already, but i cant get stickiness where can i get IK handle Attributes?
siawyuan is offline   Reply With Quote
Old 08-03-2004, 04:35 PM   #4
Kurt
Registered User
 
Kurt's Avatar
 
Join Date: May 2002
Location: Niagara Falls, Canada
Posts: 5,298
Thanks: 0
Thanked 64 Times in 64 Posts
Default

select the IK handels either in view port or in hypergraph... then once selected hit control A that will bring up the attributes in the channel box... find IK handle Attributes> find stickiness> make sure it has sticky selected.
__________________
I am enough of an artist to draw freely upon my imagination, knowledge is limited, imagination encircles the world. (Albert Einstein)

http://kurtboutilier.cgsociety.org/
Kurt is offline   Reply With Quote
Old 08-03-2004, 05:00 PM   #5
siawyuan
Subscriber
 
Join Date: Feb 2004
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Default

ok can already thanks.....
siawyuan is offline   Reply With Quote
Old 18-03-2004, 06:41 PM   #6
strarup
Subscriber
 
Join Date: Jan 2003
Location: Denmark
Posts: 338
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi siawyuan,

if you ever need to change stickyness on again... you can use this script... "bent_stickyIK" by Nathan "bentllama" Walpole... -->
http://www.highend3d.com/maya/mel/?s...animation#2357

it will make all Ikhandles to sticky...

regards

Strarup
__________________
------------------------------------------------
Alex V. U. Strarup

One mistake can ruin it all...
strarup is offline   Reply With Quote
Old 19-03-2004, 07:29 AM   #7
siawyuan
Subscriber
 
Join Date: Feb 2004
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks......
siawyuan is offline   Reply With Quote
New Thread

« Previous Thread | Next Thread »

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem solving many dynamic objects in a pile? rohiniduggal Dynamics & Special Effects 3 14-01-2011 06:26 PM
apache environment problem andrew_sorensen Simply Maya Tutorials 4 08-12-2010 02:48 PM
Strange Problem - Unable to change attributes for multiple objects anthonysw3 Technical Issues 4 04-12-2010 10:56 PM

1 Month

$34

Month-to-month billing
$34/month
Unlimited access to all videos
Project files to download
Easy to cancel at anytime
 
 

3 months

$87

Billing every 3 months
$29/month
Unlimited access to all videos
Project files to download
Easy to cancel at anytime
Save $5 per month or $15 in total compared to monthly billing with this package.

12 months

$288

Billing every 12 months
$24/month
Unlimited access to all videos
Project files to download
Easy to cancel at anytime
Save $10 per month or $120 in total compared to monthly billing with this package.

Your plan will automatically renew. You can cancel at any time via your PayPal account to avoid being charged again.

You can view the FAQ on our video plans here. You can contact us directly here. By clicking one of the buttons above, you agree to our Terms and Privacy Policy.