SimplyMaya Forums

Welcome to the forum, feel free to ask questions here.

Register FAQ Members List Calendar Mark Forums Read

New Thread
 
Thread Tools
Old 09-09-2006, 12:54 PM   #1
iron_tick
Subscriber
 
iron_tick's Avatar
 
Join Date: Sep 2002
Location: Chicagoland USA
Posts: 719
Thanks: 0
Thanked 0 Times in 0 Posts
Default Displacement map, Bump Map Problem

When i assign a bump map to my model after I set my approx node and displacement map, I get a strange result. My UV's are set correctly and ive tested my color and bump on my model before displacement so the layout appears to be fine. Feature displacement is off rendered in Maya 6 w/ Mental ray. The problem appears to occure after attaching approx node to object.
The second image is my zbrsuh render.
Attached Thumbnails
Click image for larger version

Name:	problem 1.jpg
Views:	80
Size:	195.1 KB
ID:	30628  
__________________
<html><font size=2>
<font color="blue">
And after calming me down with some orange slices and some fetal spooning,
E.T. revealed to me his singular purpose.

--TOOL, 10,000 Days---

</font></pre>
</html>
iron_tick is offline   Reply With Quote
Old 09-09-2006, 12:56 PM   #2
iron_tick
Subscriber
 
iron_tick's Avatar
 
Join Date: Sep 2002
Location: Chicagoland USA
Posts: 719
Thanks: 0
Thanked 0 Times in 0 Posts
Default

This is the same model with 1 smooth and higher displacement settings. No bump map applied and lacking detail.
Attached Thumbnails
Click image for larger version

Name:	problem 2.jpg
Views:	79
Size:	14.9 KB
ID:	30629  
__________________
<html><font size=2>
<font color="blue">
And after calming me down with some orange slices and some fetal spooning,
E.T. revealed to me his singular purpose.

--TOOL, 10,000 Days---

</font></pre>
</html>
iron_tick is offline   Reply With Quote
Old 09-09-2006, 12:58 PM   #3
iron_tick
Subscriber
 
iron_tick's Avatar
 
Join Date: Sep 2002
Location: Chicagoland USA
Posts: 719
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Again with the bump map applied and the lambert to Blinn. The Bump map was set 3 times higher than needed for this sample. Notice that it only effects certain areas of my model. It's as if the displacement isnt affecting the bump map at all.
Attached Thumbnails
Click image for larger version

Name:	problem 3 copy.jpg
Views:	77
Size:	78.2 KB
ID:	30630  
__________________
<html><font size=2>
<font color="blue">
And after calming me down with some orange slices and some fetal spooning,
E.T. revealed to me his singular purpose.

--TOOL, 10,000 Days---

</font></pre>
</html>
iron_tick is offline   Reply With Quote
Old 09-09-2006, 01:41 PM   #4
iron_tick
Subscriber
 
iron_tick's Avatar
 
Join Date: Sep 2002
Location: Chicagoland USA
Posts: 719
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok, seems like my base model has some type of problem. Still havent pinned it down yet. Why would an OBJ file cause this to happen?
__________________
<html><font size=2>
<font color="blue">
And after calming me down with some orange slices and some fetal spooning,
E.T. revealed to me his singular purpose.

--TOOL, 10,000 Days---

</font></pre>
</html>
iron_tick is offline   Reply With Quote
Old 09-09-2006, 03:41 PM   #5
iron_tick
Subscriber
 
iron_tick's Avatar
 
Join Date: Sep 2002
Location: Chicagoland USA
Posts: 719
Thanks: 0
Thanked 0 Times in 0 Posts
Default

ok check this out. When i dont use the approx editor i get the bump to show but my displacement detail is way low.
Attached Thumbnails
Click image for larger version

Name:	problem 1-2.jpg
Views:	69
Size:	185.7 KB
ID:	30631  
__________________
<html><font size=2>
<font color="blue">
And after calming me down with some orange slices and some fetal spooning,
E.T. revealed to me his singular purpose.

--TOOL, 10,000 Days---

</font></pre>
</html>
iron_tick is offline   Reply With Quote
Old 09-09-2006, 04:23 PM   #6
vladimirjp
Subscriber
 
vladimirjp's Avatar
 
Join Date: Jun 2003
Location: stuck in the 90's boston, USA
Posts: 1,871
Thanks: 0
Thanked 4 Times in 3 Posts
Default

post a pic of your settings for the approx nodes.
there s 2 approx node u can use in maya.
__________________
Image dump
vladimirjp is offline   Reply With Quote
Old 09-09-2006, 07:06 PM   #7
iron_tick
Subscriber
 
iron_tick's Avatar
 
Join Date: Sep 2002
Location: Chicagoland USA
Posts: 719
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Feature displacement is off
all maps created in zbrush
All maps correctly orientated to uv direction
Attached Thumbnails
Click image for larger version

Name:	problem 6 copy.jpg
Views:	67
Size:	172.0 KB
ID:	30645  
__________________
<html><font size=2>
<font color="blue">
And after calming me down with some orange slices and some fetal spooning,
E.T. revealed to me his singular purpose.

--TOOL, 10,000 Days---

</font></pre>
</html>
iron_tick is offline   Reply With Quote
Old 09-09-2006, 07:49 PM   #8
vladimirjp
Subscriber
 
vladimirjp's Avatar
 
Join Date: Jun 2003
Location: stuck in the 90's boston, USA
Posts: 1,871
Thanks: 0
Thanked 4 Times in 3 Posts
Default

everything looks good to me.
are you using the disp exporter to export your disp maps?

i dont usee that thing and i get pretty good results with 16bit tiffs.
simply exporting the old way.
i would also use a normal map instead of a bump map.

not much more i can help with. all seems ok from those pics.
the problem must be with Z and not maya.
chances are its the maps themselves.
__________________
Image dump
vladimirjp is offline   Reply With Quote
Old 10-09-2006, 03:33 AM   #9
iron_tick
Subscriber
 
iron_tick's Avatar
 
Join Date: Sep 2002
Location: Chicagoland USA
Posts: 719
Thanks: 0
Thanked 0 Times in 0 Posts
Default

OK, ive done a few little tests with maya and im getting the same results. made a sphere and assigned two maps. one generic pic file to displace it and a noise file to bump. All is well until i get to the approx node. Is it that simple? approx node can't handle bump maps? can anyone else reproduce this problem?
__________________
<html><font size=2>
<font color="blue">
And after calming me down with some orange slices and some fetal spooning,
E.T. revealed to me his singular purpose.

--TOOL, 10,000 Days---

</font></pre>
</html>
iron_tick is offline   Reply With Quote
Old 10-09-2006, 07:03 AM   #10
vladimirjp
Subscriber
 
vladimirjp's Avatar
 
Join Date: Jun 2003
Location: stuck in the 90's boston, USA
Posts: 1,871
Thanks: 0
Thanked 4 Times in 3 Posts
Default

u need to also convert your poly base mesh to a subD surface. yours looks like its still a cage poly.
convert it first then apply the approx nodes. try that.
__________________
Image dump
vladimirjp is offline   Reply With Quote
Old 10-09-2006, 07:25 AM   #11
iron_tick
Subscriber
 
iron_tick's Avatar
 
Join Date: Sep 2002
Location: Chicagoland USA
Posts: 719
Thanks: 0
Thanked 0 Times in 0 Posts
Default

been through that one too, no better. I even ran a script i got from zbrush site to preset my maya settings still wont work. I loaded maya on a new system, still didnt work.
__________________
<html><font size=2>
<font color="blue">
And after calming me down with some orange slices and some fetal spooning,
E.T. revealed to me his singular purpose.

--TOOL, 10,000 Days---

</font></pre>
</html>
iron_tick is offline   Reply With Quote
Old 10-09-2006, 08:00 AM   #12
iron_tick
Subscriber
 
iron_tick's Avatar
 
Join Date: Sep 2002
Location: Chicagoland USA
Posts: 719
Thanks: 0
Thanked 0 Times in 0 Posts
Default

http://www.quickdump.com/files/1942806357.html this is the disp map


http://www.quickdump.com/files/636343415.html this is the bump map

and attached is the OBJ.

I'm using Maya 6.0 let me know if you find a way.
Attached Files
File Type: zip wh.zip (110.1 KB, 16 views)
__________________
<html><font size=2>
<font color="blue">
And after calming me down with some orange slices and some fetal spooning,
E.T. revealed to me his singular purpose.

--TOOL, 10,000 Days---

</font></pre>
</html>
iron_tick is offline   Reply With Quote
Old 10-09-2006, 08:56 AM   #13
iron_tick
Subscriber
 
iron_tick's Avatar
 
Join Date: Sep 2002
Location: Chicagoland USA
Posts: 719
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Looks promising. i think it's the damn displacement map.
:angery:
__________________
<html><font size=2>
<font color="blue">
And after calming me down with some orange slices and some fetal spooning,
E.T. revealed to me his singular purpose.

--TOOL, 10,000 Days---

</font></pre>
</html>
iron_tick is offline   Reply With Quote
Old 10-09-2006, 09:54 AM   #14
vladimirjp
Subscriber
 
vladimirjp's Avatar
 
Join Date: Jun 2003
Location: stuck in the 90's boston, USA
Posts: 1,871
Thanks: 0
Thanked 4 Times in 3 Posts
Default

that site wont let me download the files.

why are they so big, u should scale them 1/2 size and rar them.
also using .map file type only benefits in cases of network rendering.
__________________
Image dump
vladimirjp is offline   Reply With Quote
Old 10-09-2006, 10:12 AM   #15
iron_tick
Subscriber
 
iron_tick's Avatar
 
Join Date: Sep 2002
Location: Chicagoland USA
Posts: 719
Thanks: 0
Thanked 0 Times in 0 Posts
Default

the .map came out better than the 32 bit tif. what type do you use for export?

better yet, if you use zbrush, what setting do you use?
__________________
<html><font size=2>
<font color="blue">
And after calming me down with some orange slices and some fetal spooning,
E.T. revealed to me his singular purpose.

--TOOL, 10,000 Days---

</font></pre>
</html>
iron_tick is offline   Reply With Quote
New Thread

« Previous Thread | Next Thread »

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem solving many dynamic objects in a pile? rohiniduggal Dynamics & Special Effects 3 14-01-2011 06:26 PM
Strange Problem - Unable to change attributes for multiple objects anthonysw3 Technical Issues 4 04-12-2010 10:56 PM

1 Month

$34

Month-to-month billing
$34/month
Unlimited access to all videos
Project files to download
Easy to cancel at anytime
 
 

3 months

$87

Billing every 3 months
$29/month
Unlimited access to all videos
Project files to download
Easy to cancel at anytime
Save $5 per month or $15 in total compared to monthly billing with this package.

12 months

$288

Billing every 12 months
$24/month
Unlimited access to all videos
Project files to download
Easy to cancel at anytime
Save $10 per month or $120 in total compared to monthly billing with this package.

Your plan will automatically renew. You can cancel at any time via your PayPal account to avoid being charged again.

You can view the FAQ on our video plans here. You can contact us directly here. By clicking one of the buttons above, you agree to our Terms and Privacy Policy.