SimplyMaya Forums

Welcome to the forum, feel free to ask questions here.

Home / forum / Lounges / Technical Issues / Rigid Body issues
Register FAQ Members List Calendar Mark Forums Read

New Thread
 
Thread Tools
Old 27-12-2008, 10:41 AM   #1
sunilgs
Subscriber
 
Join Date: Nov 2007
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default Rigid Body issues

Hey All

I don't know what happened but my active rigid body system does not animate. It just stays in one position

I'm not sure if I did something with Cache settings or something like that but I dont know how to fix it.

Actually pretty much everything in my dynamics does nothing from effects to rigid bodies.

Has anyone had this issue, or know how to resolve it?

I would appreciate any help I can get.

Thanks

Specs
Maya 8.5 and 2009
Mac OSXm leopard 10.5
4gbram
sunilgs is offline   Reply With Quote
Old 27-12-2008, 10:43 AM   #2
sunilgs
Subscriber
 
Join Date: Nov 2007
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default

BTW the rigid body system has work fine it the past. But all of a sudden it stopped working.
sunilgs is offline   Reply With Quote
Old 27-12-2008, 05:23 PM   #3
dave_baer
Moderator
 
dave_baer's Avatar
 
Join Date: Sep 2002
Location: Plantation, Florida
Posts: 1,568
Thanks: 0
Thanked 12 Times in 9 Posts
Default

You mean it stopped working on your current project or just stopped working totally?

If it's just that project, my best advice would be to start over. Since you yourself said "I'm not sure if I did something with Cache settings or something like that" then I'm not sure if there's anything anyone can do to help you.

Try deleting Maya's preferences folder to see if that resets it. Go to Start Menu > My Documents > (User if there is more than one user) > Maya > 2008(9) and then delete the Prefs folder. The next time you start Maya, it will ask to use old preferences or create new ones. Create new ones. See if that fixes it.
__________________
Dave Baer
Professor of Digital Arts
Digital Media Arts College
Boca Raton, Florida
dbaer@dmac.edu
dave_baer is offline   Reply With Quote
Old 27-12-2008, 10:15 PM   #4
sunilgs
Subscriber
 
Join Date: Nov 2007
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks for the reply

I deleted my preferences but still my rigid bodies do not animate, nor fall.

This happens in any new or current project.


Im thinking about reinstalling maya however I thought deleting the system preferences would have the same effect.


Would love to hear more suggestions if anyone has any. Thanks!
sunilgs is offline   Reply With Quote
Old 28-12-2008, 02:59 AM   #5
dave_baer
Moderator
 
dave_baer's Avatar
 
Join Date: Sep 2002
Location: Plantation, Florida
Posts: 1,568
Thanks: 0
Thanked 12 Times in 9 Posts
Default

Just out of curiosity, you are attaching fields like gravity to these dynamic bodies, yes?
__________________
Dave Baer
Professor of Digital Arts
Digital Media Arts College
Boca Raton, Florida
dbaer@dmac.edu
dave_baer is offline   Reply With Quote
Old 28-12-2008, 03:37 AM   #6
sunilgs
Subscriber
 
Join Date: Nov 2007
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default

okay it works! I had to go to solver>memory cache>delete , and now the rigid bodies seem to work.

However some of the effects still don't work. Mainly the shatter. It does absolutely nothing, and does not display any results. Anyone else experience this?

Thanks for the help Dave? Actually resetting the preferences helped solve some rendering issues (I used to have to select the objects in order to see them rendered not anymore)
sunilgs is offline   Reply With Quote
Old 28-12-2008, 03:42 AM   #7
sunilgs
Subscriber
 
Join Date: Nov 2007
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default

***Thanks for the help Dave!
sunilgs is offline   Reply With Quote
Old 28-12-2008, 03:56 AM   #8
sunilgs
Subscriber
 
Join Date: Nov 2007
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Okay problem solved, When it doubt do two things:

1. Delete preferences!
2. Delete History!

These are two very simple rules all CG artists should live by
sunilgs is offline   Reply With Quote
New Thread

« Previous Thread | Next Thread »

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off

1 Month

$34

Month-to-month billing
$34/month
Unlimited access to all videos
Project files to download
Easy to cancel at anytime
 
 

3 months

$87

Billing every 3 months
$29/month
Unlimited access to all videos
Project files to download
Easy to cancel at anytime
Save $5 per month or $15 in total compared to monthly billing with this package.

12 months

$288

Billing every 12 months
$24/month
Unlimited access to all videos
Project files to download
Easy to cancel at anytime
Save $10 per month or $120 in total compared to monthly billing with this package.

Your plan will automatically renew. You can cancel at any time via your PayPal account to avoid being charged again.

You can view the FAQ on our video plans here. You can contact us directly here. By clicking one of the buttons above, you agree to our Terms and Privacy Policy.