SimplyMaya Forums

Welcome to the forum, feel free to ask questions here.

Home / forum / Lounges / Maya Basics & Newbie Lounge / obj import -- polys don't texture
Register FAQ Members List Calendar Mark Forums Read

New Thread
 
Thread Tools
Old 16-06-2003, 04:09 AM   #1
markw2003
Subscriber
 
markw2003's Avatar
 
Join Date: Mar 2003
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Question obj import -- polys don't texture

Help please. I've been importing OBJ files into Maya and having trouble applying shaders. I've used the stone shaders from the aliaswavefront site on polygons and nurbs made within Maya -- no problem -- but applied to my imported objects in the same file only the basic color, transparency effects show up. No bump, for instance. Something to do with the 2d textures...?

This has happened on mac and pc for me.
markw2003 is offline   Reply With Quote
Old 16-06-2003, 04:45 AM   #2
NitroLiq
Moderator
 
NitroLiq's Avatar
 
Join Date: Nov 2002
Location: New York
Posts: 2,133
Thanks: 0
Thanked 10 Times in 9 Posts
Default

Did you double-check the shader's attributes to make certain there's something plugged into the bump node when applied to the imported object?
__________________
"Terminat Bora Diem, Terminal Auctor opus."

Last edited by NitroLiq : 16-06-2003 at 04:48 AM.
NitroLiq is offline   Reply With Quote
Old 16-06-2003, 08:34 AM   #3
caligraphics
Registered User
 
caligraphics's Avatar
 
Join Date: Mar 2003
Location: Billund, Denmark
Posts: 992
Thanks: 0
Thanked 0 Times in 0 Posts
Default

and check how the UV are laid out
__________________
Carsten Lind
Senior 3D Artist,
Maya Software Manager & Maya Instructor
LEGO Systems A/S
caligraphics is offline   Reply With Quote
Old 16-06-2003, 01:47 PM   #4
markw2003
Subscriber
 
markw2003's Avatar
 
Join Date: Mar 2003
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Here's my test example. Cube and ring are both textured with the same shader. The ring ignores images attached to the color node and just displays a basic default color.

By "check how the uvs are laid out" do you mean cylindrical mapping, automatic, etc? I've tried both; the UV texture editor shows the shader applied. Otherwise, my semi-newbie brain doesn't understand.
Attached Thumbnails
Click image for larger version

Name:	lakelandtest.jpg
Views:	33
Size:	6.3 KB
ID:	8012  
markw2003 is offline   Reply With Quote
Old 16-06-2003, 04:32 PM   #5
markw2003
Subscriber
 
markw2003's Avatar
 
Join Date: Mar 2003
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

just sos you knows, I tried out the results mentioned in :

http://forums.simplymaya.com/showthr...&threadid=6299

Used the Relationship Editor to create a new uv set and connected the texture nodes to it -- got some action from that. Not sure which type of mapping I used... maybe planar, anyway, there you go...
markw2003 is offline   Reply With Quote
New Thread

« Previous Thread | Next Thread »

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off

1 Month

$34

Month-to-month billing
$34/month
Unlimited access to all videos
Project files to download
Easy to cancel at anytime
 
 

3 months

$87

Billing every 3 months
$29/month
Unlimited access to all videos
Project files to download
Easy to cancel at anytime
Save $5 per month or $15 in total compared to monthly billing with this package.

12 months

$288

Billing every 12 months
$24/month
Unlimited access to all videos
Project files to download
Easy to cancel at anytime
Save $10 per month or $120 in total compared to monthly billing with this package.

Your plan will automatically renew. You can cancel at any time via your PayPal account to avoid being charged again.

You can view the FAQ on our video plans here. You can contact us directly here. By clicking one of the buttons above, you agree to our Terms and Privacy Policy.