SimplyMaya Forums

Welcome to the forum, feel free to ask questions here.


SM Forums / Maya Questions / Maya Technical Issues / Unusual Artifacts

Maya Technical Issues Post all your interface and configuration related problems with Maya software here.

Join the conversation. Reply to post
 
Thread Tools
06-08-2008, 04:07 AM   #1
dockode
Registered User
 
dockode's Avatar
 
Join Date: Sep 2003
Location: Florida
Posts: 259
Unusual Artifacts
I'm having some odd issues when rendering with mental ray as of late. Any time i add a light other than the default light to the scene strange artifacts start showing up in the shadows of my models.

I'm attaching an example of what I'm talking about.

There is no geometry on the model that could be producing those sharp points, and I'm completely baffled as to why they are showing up.

To clarify, rendering with anything other than mental ray is not an option for me. I also believe that there must be a simple solution to my problem, so I'm hoping some of you maya veterans can help me out here. I am currently using version 8.5 of the software, and I am rendering using Production: Fine Trace settings in mental ray. I've also included the physical sky and sun, but the artifacts occur as soon as any other type of light is added to the scene.

My first guess is that it's a normals issue, but I can't seem to get it resolved. Any attempts at fixing it so far have resulted in worse artifacts.

Thanks in advance for any assistance you all can lend.
Attached Thumbnails
Click image for larger version

Name:	shadow artifacts.jpg
Views:	97
Size:	57.1 KB
ID:	39763  
__________________
...and that is how I saved the world.
  Reply with quote
06-08-2008, 04:16 AM   #2
Joopson
Registered User
 
Joopson's Avatar
 
Join Date: Jul 2005
Location: Boston, MA
Posts: 2,314
Those aren't just shadows? hmm, can't help you much. My guess would be normals too, or something to do with the raytracing quality.
__________________
Environment Artist @ Plastic Piranha
www.joopson.com
  Reply with quote
06-08-2008, 06:46 AM   #3
arran
Registered User
 
arran's Avatar
 
Join Date: Dec 2005
Location: Brooklyn, NY
Posts: 3,708
let's see a wire. are you sure the vertices are merged or there aren't hidden faces?
__________________
arran3D

arran3D blog
  Reply with quote
06-08-2008, 08:21 AM   #4
dockode
Registered User
 
dockode's Avatar
 
Join Date: Sep 2003
Location: Florida
Posts: 259
I might post a wire tomorrow, I'm a bit lazy right now to open up and capture. It's 3 am. I am 100% positive that the vertices are all well connected/welded and that there is no additional hidden geometry in those areas.

This model is only an example of the problem. This occurs on most models I attempt to render with mental ray. So it's not limited to a special case in my observations. I've tested it with several models and the results are the same. Not to mention annoying. I appreciate your suggestions, but they are things I checked for.

Again thank you all for taking the time to read this post and post your input, I really do appreciate it.

On an additional note, a friend of mine is having the same problem with mental ray. He tried to edit the normals and it did affect the output, not always in a good way.
__________________
...and that is how I saved the world.
  Reply with quote
10-08-2008, 12:08 PM   #5
dockode
Registered User
 
dockode's Avatar
 
Join Date: Sep 2003
Location: Florida
Posts: 259
Bumperoni
In an attempt to demonstrate that this issue has nothing to do with my model, I've downloaded a model created by Antony Ward. He is a professional in the industry and has worked for EA and Atari. This file is generously provided by Mr. Ward for free as part of a tutorial on his web site.

Clicky: Mr. Wards Tutorial

Once ambient occlusion is applied to the model you can see the same types of artifacts on the characters breasts. You can download and test the model for yourselves. And let me know if you get the same artifacts. I used Mental Ray, Production: Fine Trace settings. Created a Surface Shader and attached the mib_ambientocclusion texture to it and then applied that to the model.

Thanks again for all your help guys.
Attached Thumbnails
Click image for larger version

Name:	antonywardssarapezzini.png
Views:	72
Size:	108.6 KB
ID:	39825  
__________________
...and that is how I saved the world.
  Reply with quote
10-08-2008, 01:03 PM   #6
Joopson
Registered User
 
Joopson's Avatar
 
Join Date: Jul 2005
Location: Boston, MA
Posts: 2,314
I get that problem with that model, but only when using ambient occlusion
__________________
Environment Artist @ Plastic Piranha
www.joopson.com
  Reply with quote
Reply

Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
Light Fog Artifacts prat391 Lighting & Rendering 0 21-01-2014 10:04 PM
Displacement map geometry artifacts NShaun Maya Materials & Textures 7 31-07-2012 11:41 AM
Ploygon/FillHole leaves artifacts on object Tom Knowles Maya Basics & Newbie Lounge 11 22-07-2010 08:56 PM
Artifacts in DOF - Mental Ray render sjurick Lighting & Rendering 6 21-11-2005 05:01 PM
pfx shadow artifacts kbrown Maya Materials & Textures 3 13-10-2002 10:05 PM