SimplyMaya Forums

Welcome to the forum, feel free to ask questions here.


SM Forums / Maya Questions / Lighting & Rendering / MR Normal map & Reflection Problem! Help!

Lighting & Rendering General Lighting, Camera & Rendering Related Topics

Join the conversation. Reply to post
 
Thread Tools
27-06-2015, 03:35 AM   #1
martingilbert3d
Registered User
 
Join Date: Jun 2015
Posts: 4
MR Normal map & Reflection Problem! Help!
Hi everyone,

I'm having an problem with reflection and my normal maps that I can't figure out.

I'm building some log booms and only a small number of my logs are actually reflecting the way that they should be. My normals are all fine, all histories are deleted, everything is cleared.

If I go into my MR shader for the logs and set reflection to 0.00, then all the logs look consistent. as soon as I add any reflection (would like to have it set to ~0.35) I only get a few logs catching light and reflecting. Crank the reflection to 1.0 and the problem is really obvious (see attached pic). Remove the Normal map and everything is A-OK.

-I'm using an IBL system and a number of point lights, spot lights, and two fairly strong directional lights.
-The logs have a displacement map & I'm using the MR approximation editor (LDA).
-Built my Normal map and displacement map using Crazy Bump (Have built several of each now)
-Removing displacement doesn't solve the issue.
-Removing IBL doesn't solve the issue.
-Exporting logs as OBJ (with & without normals) & then reimporting doesn't solve the issue.

Anyone here encountered this before? I hope so!

-M
Attached Thumbnails
Click image for larger version

Name:	logs_reflection_Example01.jpg
Views:	238
Size:	135.1 KB
ID:	56752   Click image for larger version

Name:	logs_reflection_Example02.jpg
Views:	181
Size:	94.7 KB
ID:	56753   Click image for larger version

Name:	logs_reflection_Example03.jpg
Views:	189
Size:	70.4 KB
ID:	56754   Click image for larger version

Name:	logs_reflection_Example04.jpg
Views:	184
Size:	196.3 KB
ID:	56755  
  Reply with quote
27-06-2015, 04:44 AM   #2
NextDesign
Technical Director
 
NextDesign's Avatar
 
Join Date: Feb 2004
Posts: 2,988
Can you post the normal map and let us know where the dark logs occur in the texture space? It could be that the dark regions are caused by the normal map flipping the normals.

One thing you could check is to export the displaced normals right out of Maya, and compare it with the output of CrazyBump to see if there is anything grossly different between the two. Did you have shape recognition on when you exported the normals from CrazyBump?
__________________
Imagination is more important than knowledge.
  Reply with quote
27-06-2015, 06:14 AM   #3
martingilbert3d
Registered User
 
Join Date: Jun 2015
Posts: 4
Here are some compressed versions of the maps I have made. It's a tiling texture and the logs are randomly placed over it - there isn't any connection btwn darkness on the map & darkness in the render (as far as I can tell).

I'm not sure what you mean by "export the displaced normals right out of Maya" - could you elaborate? :-)

Thanks NextDesign!
Attached Thumbnails
Click image for larger version

Name:	Log_Nrm_Example_01_FromCB.jpg
Views:	109
Size:	269.4 KB
ID:	56756   Click image for larger version

Name:	Log_Disp_Example_01_FromCB.jpg
Views:	114
Size:	112.4 KB
ID:	56757   Click image for larger version

Name:	Log_Diff_Example_01_FromCB.jpg
Views:	106
Size:	245.7 KB
ID:	56758  
  Reply with quote
29-06-2015, 05:39 AM   #4
martingilbert3d
Registered User
 
Join Date: Jun 2015
Posts: 4
Got it sorted out - it was the normals direction. Had to rotate the normals on the dark logs 180 degrees and they rendered properly. Had never had that happen before...
  Reply with quote
Reply

Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
Normal Map Problem GeorgiStamenov Maya Basics & Newbie Lounge 5 04-03-2014 09:11 PM
Normal Map Mayastatic Maya Basics & Newbie Lounge 2 17-09-2007 04:02 AM
normal map texture? Mayastatic Maya Materials & Textures 0 14-09-2007 01:05 PM
normal map question Thomps Maya Basics & Newbie Lounge 0 26-06-2007 12:08 AM
Bump Map problem Jaroehl Maya Basics & Newbie Lounge 2 20-02-2006 01:04 PM