Maya Training

Creating characters In Maya and Zbrush

Maya Training

Creating character renders in Maya 2017 and Arnold

Maya Training

Spach-Alspaugh House the complete courseware
You are here > Home > SimplyMaya Community Forums
Loading

Welcome to Simply Maya

Please Sign in or Sign up for an account

Member Login

Lost your password?

Not a member yet? Sign Up!

Old 10-09-2012, 01:08 PM   #1
adamj1910
Registered User
 
Join Date: Sep 2012
Posts: 6
Thanks: 3
Thanked 0 Times in 0 Posts
Default Revolved polygon only showing back faces?????

Hi All!

There will be a time where I don't ask questions about every small thing, but as you can see below, I extruded a few faces and when you move orbit around the object it changes place, so even though I extruded it with faces on the front and sides you can't see them.

http://i966.photobucket.com/albums/a...910/bulb-1.jpg

http://i966.photobucket.com/albums/a...910/bulb-2.jpg

What's happening?!?!? lol

Thanks
adamj1910 is offline   Reply With Quote
Old 10-09-2012, 01:44 PM   #2
dustykhan
Subscriber
 
dustykhan's Avatar
 
Join Date: Apr 2012
Posts: 187
Thanks: 18
Thanked 20 Times in 19 Posts
Default

The first thing I would do is check the normals which off the top of my head is under display -> polygons -> face normals, and if you have backface culling on (display -> polygons -> backface culling) and it is also under the view or show options I believe ...?
dustykhan is offline   Reply With Quote
The Following User Says Thank You to dustykhan For This Useful Post:
adamj1910 (18-09-2012)
Old 10-09-2012, 04:50 PM   #3
ctbram
Moderator
 
ctbram's Avatar
 
Join Date: Jan 2004
Location: Michigan, USA
Posts: 2,996
Thanks: 42
Thanked 582 Times in 532 Posts
Default

It appears you have the object normals inverted AND you have backface culling on so you are only seeing the inside faces.

To check the normals go to the lighting drop down and uncheck two-sided lighting. Anything with reversed normals will be black. However, with backface culling on you will not see anything change.

To check backface culling select the object go to the shading drop down and make sure backface culling is unchecked.


IMPORTANT - The problem here is in a moment of total RETARDATION the makers of maya allow like 15 different and independent ways to turn on backface culling.

So, if you have the item selected and backface culling is not checked in the shading drop down then in the command window type: ToggleBackfaceGeometry;

You must be very careful in maya hitting random keys as many hotkeys can do things like turn on backface culling and this can drive you literally insane because it's nearly impossible to figure out what feature you accidentally turned on to be able to undo it.
__________________
"If I have seen further it is by standing on the shoulders of giants." Sir Isaac Newton, 1675
ctbram is offline   Reply With Quote
The Following User Says Thank You to ctbram For This Useful Post:
adamj1910 (18-09-2012)
Old 18-09-2012, 11:09 AM   #4
adamj1910
Registered User
 
Join Date: Sep 2012
Posts: 6
Thanks: 3
Thanked 0 Times in 0 Posts
Default

Originally Posted by dustykhan View Post
The first thing I would do is check the normals which off the top of my head is under display -> polygons -> face normals, and if you have backface culling on (display -> polygons -> backface culling) and it is also under the view or show options I believe ...?
cheers dustykhan ill have a look later and get back to you!
adamj1910 is offline   Reply With Quote
Old 18-09-2012, 11:10 AM   #5
adamj1910
Registered User
 
Join Date: Sep 2012
Posts: 6
Thanks: 3
Thanked 0 Times in 0 Posts
Default

Originally Posted by ctbram View Post
It appears you have the object normals inverted AND you have backface culling on so you are only seeing the inside faces.

To check the normals go to the lighting drop down and uncheck two-sided lighting. Anything with reversed normals will be black. However, with backface culling on you will not see anything change.

To check backface culling select the object go to the shading drop down and make sure backface culling is unchecked.


IMPORTANT - The problem here is in a moment of total RETARDATION the makers of maya allow like 15 different and independent ways to turn on backface culling.

So, if you have the item selected and backface culling is not checked in the shading drop down then in the command window type: ToggleBackfaceGeometry;

You must be very careful in maya hitting random keys as many hotkeys can do things like turn on backface culling and this can drive you literally insane because it's nearly impossible to figure out what feature you accidentally turned on to be able to undo it.
oh right, rookie mistake, i'll give it a try later, thanks ctbram!! very informative answer lol
cheers
adamj1910 is offline   Reply With Quote
Reply


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help with Faces srlake314 Maya Basics & Newbie Lounge 24 22-06-2012 04:32 PM
polygon plane used for image plane issues kvnmcwebn Maya Basics & Newbie Lounge 10 08-12-2011 05:06 AM
Create Polygon Tool / Polygon Squares? PenPixels Maya Basics & Newbie Lounge 6 22-11-2011 02:49 PM
UV per faces (polygon) ? XXX1 Maya Basics & Newbie Lounge 8 13-10-2011 06:27 PM
Face Selection: highlights nearby faces dannyboiii Maya Basics & Newbie Lounge 2 10-04-2011 11:59 AM

Thread Tools





A little bit about who we are
Links you might find useful
Catch up with SimplyMaya
SimplyMaya specialises in Maya tutorials. We offer over 1,000 individual Maya training videos, ranging from basic Maya tutorials through to intermediate Maya tutorials. Our tutorials are created by instructors with industry experience and are designed to get you up and running in Maya quickly without making it seem like hard work.

Copyright © 1999-2017 SimplyMaya - vBulletin® Copyright © 2000-2017, Jelsoft Enterprises Ltd.