SimplyMaya Forums

Welcome to the forum, feel free to ask questions here.

SM Forums / Maya Questions / Dynamics & Special Effects / XGen rendering issues

Dynamics & Special Effects Maya Particles, nDynamics, Fluids, Rigid Bodies & General VFX

Join the conversation. Reply to post
Thread Tools
12-11-2014, 08:13 AM   #1
Registered User
Join Date: Nov 2014
Posts: 3
XGen rendering issues
Hi guys,

I was recently working on your tutorial “creating a pegasus using xgen” on digital tutors and ran into a few problems.

Everything worked fine until I tried to duplicate the left wing of the pegasus to the right.
The Wing always disappeared when I copied it over. I double checked the tutorial but I couldn’t find a solution. So I tried to do the right Wing manually. It worked, but just to a point where I can move the sliders for length, tilt, and so on. I was not able to use the same expressions from the left side. When I entered the expressions, the wing disappeared again. On every description layer and just for the right side.

Until now I haven’t found a solution for this…
I continued on the fur for the body and the hair for tail and mane. So far it worked ok. On the fur sometimes weird things happen like if I change the density value, the fur goes back into its default position and I have to style the fur from scratch (Just on the body).

I heard that the batch rendering makes problems too, so I already tried this out. And yes: My batch render is not working too. The live render works fine for me. But when I batch render, the whole fur, feathers and hairs are missing. There is just the horse model. I did it as in the tutorial: I am using mental ray renderer, set it to batch render, I exported patches for batch render, set the percent value to 100%, auto set the primitive bound, checked my render settings (rendering format: targa, correct frames and camera)… I tried a lot: updating the viewer for collections/descriptions, rendering a moving camera (checked on the animation box), the perspective cam and a camera which is not moving and of course: I set my project. My model has no animation, it is just changing the poses in every frame from 1-4. Sometimes XGen renders only the horse model, and when I try another render it sometimes renders nothing.

I am really desperate now.. I was doing research for the whole weekend on the internet and can’t find any solution for my problems. Actually there is not a lot about XGen on the internet so far.
I hope you guys could help me somehow. I really want to finish this project and continue using XGen.
I am working with the Student Version of Maya 2015 (Service Pack 5) and my renderer is mental ray.
I am using a Mac Book Pro OS X (Version 10.9.5).

Thanks in advance!
  Reply with quote
30-06-2015, 06:03 PM   #2
Registered User
Join Date: Jun 2015
Posts: 1
Sorry no one replied here! You might know by now that you have to go to File - export patches for batch render in the xgen window. That works for hair splines for me but not for the groomable splines (fur). Fur does not seem to batch render for me at all. Were you able to figure it out for those still searching for a solution?

Thank you
  Reply with quote

Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Batch Render not rendering... Miralina Maya Technical Issues 1 04-04-2014 12:25 AM
Extremely confused, Batch rendering issue! mouseyflash Lighting & Rendering 0 04-04-2013 11:06 PM
Why doesn't Mental Ray have .avi available for batch rendering? SilverFeather Maya Basics & Newbie Lounge 42 07-12-2011 08:47 PM
Why Maya? haka Maya Basics & Newbie Lounge 21 10-11-2007 11:14 PM
Batch rendering seems to repeat itself alienscience Maya Basics & Newbie Lounge 7 01-02-2005 08:19 PM