SimplyMaya Forums

Welcome to the forum, feel free to ask questions here.


SM Forums / Maya Questions / Lighting & Rendering / Render is wrong in Orthographic cam

Lighting & Rendering General Lighting, Camera & Rendering Related Topics

Join the conversation. Reply to post
 
Thread Tools
29-05-2017, 10:21 AM   #1
Ouran
Registered User
 
Join Date: May 2017
Posts: 2
Render is wrong in Orthographic cam
Hi,

I have an issue when rendering xgen hair in Arnold. I'm using the same AlHair shader on all strands.

In perspective view, all strands correctly.

In any non perspective camera, the strands are rendered wrong. If I take a non perspective camera that renders wrong, and change its Camera Type to perspective in the Camera Attribute's Arnold tab, it renders correctly. If I switch it back to orthographic it renders wrong again.

Could you help me with this issue? I need to render those strands in an orthographic camera.
Attached Thumbnails
Click image for larger version

Name:	perspective_view.JPG
Views:	47
Size:	124.2 KB
ID:	57533   Click image for larger version

Name:	orthographic_view.JPG
Views:	45
Size:	189.0 KB
ID:	57534  
  Reply with quote
30-05-2017, 01:56 AM   #2
David
SM Site Programmer
 
David's Avatar
 
Join Date: Apr 2002
Posts: 3,124
It's a lighting issue i believe. See the shots below, as you can see it's the same thing you're getting. It's not an error adjust your lighting to get the look your going for in the orthographic view.

How much highlight you get on hair will depend on the light angle, this angle will change as you move the camera http://www.3drender.com/glossary/fresneleffect.htm

Adjust your light source/s see images below. First 2 are with the light in the same place as you can see i've replicated the issue your having. Last image is after i changed the direction of the light source

Hope it helps
David
Attached Thumbnails
Click image for larger version

Name:	forum_hair_01.jpg
Views:	47
Size:	151.4 KB
ID:	57535   Click image for larger version

Name:	forum_hair_02.jpg
Views:	44
Size:	118.8 KB
ID:	57536   Click image for larger version

Name:	forum_hair_03.jpg
Views:	39
Size:	135.4 KB
ID:	57537  
__________________
Worst Response To A Crisis:
From a readers' Q and A column in TV GUIDE: "If we get involved in a nuclear war, would the electromagnetic pulses from exploding bombs damage my videotapes?"
  Reply with quote
30-05-2017, 07:04 PM   #3
Ouran
Registered User
 
Join Date: May 2017
Posts: 2
Thanks for taking the time to do these tests David!

I've conducted the following test: creating a perspective cam that matches the orthographic cam almost 1:1 by playing with focal length etc. The result is: the perspective cam renders completely differently from the ortho cam even through they're framing exactly the same thing.

Therefore, I think it disproves this issue being created by the lights. What do you think ?

I guess I solved my problem by replicating the ortho cam's results with a perspective cam but I'm still curious why would the two cameras render completely different results...
  Reply with quote
30-05-2017, 08:19 PM   #4
David
SM Site Programmer
 
David's Avatar
 
Join Date: Apr 2002
Posts: 3,124
Well that's weird to my knowledge that should not happen, i'm glad you got the result you where after in the end.

I'll have a play with xgen and see if i can get it to do the same thing i'd be interested to know why it's happening.
__________________
Worst Response To A Crisis:
From a readers' Q and A column in TV GUIDE: "If we get involved in a nuclear war, would the electromagnetic pulses from exploding bombs damage my videotapes?"
  Reply with quote
Reply

Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
RENDER VS BATCH RENDER VS VECTOR! Albepie Lighting & Rendering 0 24-03-2016 12:56 PM
what's wrong with my render? shadows problem n88tr Maya Basics & Newbie Lounge 6 13-08-2010 11:33 PM
good orthographic render rejh2 Maya Basics & Newbie Lounge 1 05-06-2010 06:08 PM
suddenly cannot render existangst Maya Basics & Newbie Lounge 1 03-11-2009 11:47 AM
Render Corruption Black_Bart_GA Maya Technical Issues 2 10-10-2004 03:03 AM