SimplyMaya Forums

Welcome to the forum, feel free to ask questions here.


SM Forums / Maya Questions / Animation / HumanIK Animation problem in maya.

Animation Animation & Rigging Related Topics

Join the conversation. Reply to post
 
Thread Tools
08-09-2013, 04:09 AM   #1
eman72
Registered User
 
Join Date: Sep 2013
Posts: 3
HumanIK Animation problem in maya.
Hey everyone!
I am a novice animator and modeler. I have been learning how to work with Maya 2013 myself through youtube tutorials and Google. I am stuck with the HumanIK tool while trying to animate my model. I have a Biped model that is rigged and weighted properly. I just started messing around with the HumanIK because of the built in control curves it places on the skeleton.

The problem I am having is with the keyframes. I canít really think of a way to explain it in question form so Iíll just give an explanation of what is happening. I have a 24 frame test animation. On frame 1 and 24 I have the model standing. On frame 12 I have the model translate down on the y axis a bit, so it will return to the starting position on frame 24. I then add something simple such as moving the arm to the side on frame 18. The problem is that the arm doesn't start moving on frame 1 - 18 Ė 24, it starts on frame 12 - 18 - 24. It seems on the timeline that when I set a keyframe the whole rig gets set instead of the control I have selected. This problem is really messing me up when I am trying to animate something more complex.

Any ideas on how to fix this problem?
  Reply with quote
12-09-2013, 02:32 PM   #2
SoMym
Registered User
 
Join Date: Sep 2013
Posts: 1
Hi!

I have the same problem about setting the keys. In your Character Controls window, you can choose Full body mode (wich will set a key on all controlers), Body Part (if you select the right wirst and you set up a key, all the right arm will have a key) and Selection - logically this mode is suppose to put keys only on your selection, but this is where I'm stuck...

when I go in the Selection mode, none of my controlers work... This is really frustrating if you want to delete a key or add secondary movements without exploding all of your other curves...

I'll continue searching, and post here if I find anything...

(sorry for my poor english!)
  Reply with quote
Reply

Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
Maya to Nuke: A Render Problem Cybrex Lighting & Rendering 0 26-01-2017 05:26 PM
Maya 2016 problem - White seams along UVs roccofx Maya Technical Issues 0 16-06-2016 07:37 AM
Issues for max to maya users bertvaneeckhout Maya Modeling 23 25-09-2014 09:36 PM
Maya 2013 problem when starting: Menu set update NecroNinja34 Maya Technical Issues 2 29-01-2013 08:35 AM
Maya Lag problem!! thatsmybrand Maya Basics & Newbie Lounge 2 13-04-2009 11:51 AM