SimplyMaya Forums

Welcome to the forum, feel free to ask questions here.


SM Forums / Maya Questions / Maya Technical Issues / Referencing Problem: Child Nodes misplaced on reloading of Parent Scene

Maya Technical Issues Post all your interface and configuration related problems with Maya software here.

Join the conversation. Reply to post
 
Thread Tools
20-05-2008, 07:12 AM   #1
shekibobo
Registered User
 
Join Date: May 2008
Posts: 2
Referencing Problem: Child Nodes misplaced on reloading of Parent Scene
I'm working on a model of a room in Maya 8.5 with many different child nodes, such as stoves, fridges, counters, etc. I have one parent scene containing the walls and floor of the room directly in the file, and various other files were placed into the scene using the "File > Create Reference" command.

Once the referenced scenes are imported, I place them within the scene where necessary. When possible, I freeze transformations of the child nodes so they will be easy to return to their location if they accidentally get moved.

Here's the problem: when I save and reload the parent scene, most (but not all) of the geometry of the child nodes are reset to the origin, where they were first loaded in. The weird part, though, is that the pivot of each of these child nodes is located correctly, exactly where I placed the models in the scene before I saved it. So every time I reload the scene, I end up having to replace everything, and it's wasting a lot of time and causing incredible frustration.

For some reason, I have three models that don't have this problem. There is a swinging door, a window, and a sliding door, none of which reset themselves when the parent scene is reloaded. As far as I know, I did nothing different when referencing these models, nor is there any major difference in the structure of the child scenes.

So I guess my question is, does anyone else have this problem? Is there a solution? Am I doing something wrong? I'm fairly new to using the reference node workflow, and I love the concept, but it's killing me on this project right now.

I've attached an image to help explain the problem.
Attached Thumbnails
Click image for larger version

Name:	refprobimg.jpg
Views:	78
Size:	175.7 KB
ID:	39075  
  Reply with quote
20-05-2008, 07:58 AM   #2
shekibobo
Registered User
 
Join Date: May 2008
Posts: 2
So, after some experimentation, I found out that freezing transformations on a child node inside a parent scene cause all these problems. If I don't freeze transformations, all the child nodes remain unchanged when the parent scene is reloaded.
  Reply with quote
Reply

Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rendering Problem NoxRequiem Lighting & Rendering 6 01-04-2011 09:39 AM
Having problem with creating an environment for the scene azatrum Maya Basics & Newbie Lounge 6 29-08-2009 12:57 PM
joint parent problem leonlabyk Animation 1 06-08-2008 01:19 AM
Problem with Interior Scene Tutorial flashinstinct Simply Maya Tutorials 3 17-04-2007 03:53 AM
Problem moving nodes to layers parka Maya Basics & Newbie Lounge 3 08-04-2007 06:36 PM