SimplyMaya Forums

Welcome to the forum, feel free to ask questions here.


SM Forums / Lounges / Maya Basics & Newbie Lounge / Arnold Renderer - Glass Transparency Issue

Maya Basics & Newbie Lounge Please post in this section ONLY if your question doesn't fit in anywhere else on the forum, or if you're not sure which section it's relevant to. We also have Free streaming trial available.

Join the conversation. Reply to post
 
Thread Tools
26-01-2017, 11:21 AM   #1
frig2
Registered User
 
Join Date: Sep 2014
Posts: 6
Arnold Renderer - Glass Transparency Issue
Hi,

Just switched over to Maya 2017 and started playing around with the Arnold Renderer. Absolutely loving it so far, however I seem to be having a problem creating glass with correct transparency. I am quite confident that my material is set up correctly, I have also unchecked the Opaque option for the mesh I want to see through.

My initial reaction was that perhaps I am using too much reflection, however turning it down does not solve anything.

The material in the Hypershade is looking correct.




Unchecked Opaque option for mesh.



I have set up a red box as a test object to more clearly see the transparency issue.



Transparency not looking correct. It only reflects the backside of the room. You can also see that I am having the exact same issue with the windows on the left hand side. They are letting light pass through, however I can't see the SkyShader outside.



Here is an example where I have disabled the visibility of the window plane - the background outside is clearly there - however for some reason I cannot see it through the glass.



Is there anything I need to do differently when modelling for the Arnold Renderer? Or perhaps a setting in the Render Options that I am not aware of?

Apologies if this has been asked before, I couldn't find anything relating to the exact problem I am experiencing. The tutorials I have watched online seem to create glass in the same way without any issues, so I am at a loss trying to figure out what it is.

I am running Maya 2017 on Win8.1 64 bit with an i7 4790 and GTX745. Let me know if you need any other information.


Thank you!
  Reply with quote
26-01-2017, 01:04 PM   #2
Gen
Super Moderator
 
Gen's Avatar
 
Join Date: Dec 2006
Location: South FL
Posts: 3,518
It looks like the objects surface normals are facing the wrong direction. A quick and dirty way of telling is to uncheck "two sided lighting" in your panel's "lighting" menu (I keep this off for this very reason). It beats showing the actual normals (Display>Polygons>Face Normals) and having to fiddle with their display size because they're poking through everything and too messy looking to be useful lol. You can reverse the surface normals by selecting the object(s) or affected faces and going to Mesh Display>Reverse.
__________________
- Genny
__________________
::|| My CG Blog ||::
::|| My Maya FAQ ||::
  Reply with quote
26-01-2017, 02:38 PM   #3
frig2
Registered User
 
Join Date: Sep 2014
Posts: 6
Thanks Genny! I checked the normals and they were facing the correct way. I think, however, I have managed to find the culprit. My refraction ray depth in the render settings was only set to 2. Increasing it seems to have fixed the problem.

Thanks anyways though!
  Reply with quote
26-01-2017, 02:56 PM   #4
frig2
Registered User
 
Join Date: Sep 2014
Posts: 6
Ok, so the ray depth solved the problem with the wine glass and transparency. However, I am still having problems seeing my SkyShader through the windows.

Here's a screenshot with the window planes switched off. The SkyShader is right there.



However as soon as I reactivate the planes with the glass material - it looks like this. And yes I have made sure to uncheck the Opaque option for the mesh - the light is still shining through I just can't actually see the shader outside.


Is there a setting I have to adjust to allow seeing the SkyShader through objects?

Again thanks.
  Reply with quote
26-01-2017, 05:12 PM   #5
frig2
Registered User
 
Join Date: Sep 2014
Posts: 6
Figured it out. In the aiSky node under Render Stats the Visible in Refractions option was unchecked by default. Checking it solved the problem.
  Reply with quote
28-01-2017, 02:58 AM   #6
Gen
Super Moderator
 
Gen's Avatar
 
Join Date: Dec 2006
Location: South FL
Posts: 3,518
Nice! Thanks for sharing your solutions.
__________________
- Genny
__________________
::|| My CG Blog ||::
::|| My Maya FAQ ||::
  Reply with quote
Reply

Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
glass and shadows problem Slackfaster Lighting & Rendering 8 05-03-2015 08:55 AM
Wine Glass rendering issues in Mental Ray? JustMcCollum Lighting & Rendering 4 03-06-2014 01:03 AM
transparency issue gubar Maya Basics & Newbie Lounge 2 16-11-2007 01:26 PM
Why Maya? haka Maya Basics & Newbie Lounge 21 10-11-2007 11:14 PM
fur rendering failed????? olivermagno Maya Materials & Textures 2 21-05-2003 01:36 AM