SimplyMaya Forums

Welcome to the forum, feel free to ask questions here.

Home / forum / Lounges / Maya Basics & Newbie Lounge / Maya not keyframing properly!
Register FAQ Members List Calendar Mark Forums Read

New Thread
 
Thread Tools
Old 01-02-2011, 01:26 PM   #1
Gotmilk0112
Registered User
 
Join Date: Feb 2011
Posts: 2
Default Maya not keyframing properly!

So I'm working on a Maya animation project at school, and Maya has been working fine- until now. It doesn't keyframe properly. I'll set something like rotate, scale, move, etc and set a keyframe, then go ahead to another frame and set another keyframe, but Maya is not making an even gap between the two keyframes.

IE, I'll set Rotate Z to 5 for Frame 1, then Rotate Z to -5 for Frame 16, but when looking at it, Rotate Z will go back to 0 at frame 4, then jump up to -5 at frame 16, then go back to 0 again by frame 19 or so.

Anyone know what's going on? It's kinda stopping me from progressing any further
Gotmilk0112 is offline   Reply With Quote
Old 01-02-2011, 05:41 PM   #2
stwert
EduSciVis-er
 
Join Date: Dec 2005
Location: Toronto
Posts: 3,374
Default

Check the graph editor. That's where you'll be able to see the interpolation between the two keys, whether its linear, smoothed, or something weird like you're describing here. You'll also be able to adjust the tangents to correct the intermediate values. Hope that helps.
stwert is offline   Reply With Quote
Old 01-02-2011, 08:15 PM   #3
Gotmilk0112
Registered User
 
Join Date: Feb 2011
Posts: 2
Default

Quote:
Originally Posted by stwert View Post
Check the graph editor. That's where you'll be able to see the interpolation between the two keys, whether its linear, smoothed, or something weird like you're describing here. You'll also be able to adjust the tangents to correct the intermediate values. Hope that helps.
D'oh, why didn't I think of that? I'll try that when I get back to school either tomorrow or Thursday (Dunno if school is going to be out tomorrow due to snow)
Gotmilk0112 is offline   Reply With Quote
New Thread

« Previous Thread | Next Thread »

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
maya lagging omegaend Technical Issues 39 19-10-2012 12:18 PM
Maya Windows File corrupted on Mac cyranovb Technical Issues 4 14-07-2011 01:04 PM
glu3D and Maya bullet1968 Technical Issues 2 21-12-2010 05:27 PM
Maya Hair/Polygon Error ingram_no.7 Members Lounge 13 10-12-2010 11:27 AM
LayoutTools for Maya 2011 is here... ctbram Members Lounge 1 06-12-2010 11:32 PM