SimplyMaya Forums

Welcome to the forum, feel free to ask questions here.

Home / forum / Lounges / Maya Basics & Newbie Lounge / Selection/backface culling problem
Register FAQ Members List Calendar Mark Forums Read

New Thread
 
Thread Tools
Old 28-10-2006, 02:56 AM   #1
richtann
Registered User
 
Join Date: Mar 2004
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default Selection/backface culling problem

Hi

I'm really sorry to ask this, but i can;t find the solution and its driving me nuts. All i want to do is be able to drag select faces/vertices on a model without selecting the ones on the other side (e.g select all vertices on a nose without getting any from the back of the head)

No this seems like a very simple concept, and I'm sure it should be solved by backface culling, but whilst this makes the other faces invisible, they are still selectable.

This must be so simple any help really appreciated

Thanks

Rich
richtann is offline   Reply With Quote
Old 28-10-2006, 04:03 AM   #2
arran
Registered User
 
arran's Avatar
 
Join Date: Dec 2005
Location: Brooklyn, NY
Posts: 3,708
Thanks: 0
Thanked 9 Times in 9 Posts
Default

I know this doesn't answer your question, but another solution to your problem would be to use the Paint Selection tool. I think it is under edit. You should be able to use that tool to easily select the surface components of an object without selecting the back faces.

There is a way to do it with backface culling, but I am at work right now and can't check.

Have you tried a simply maya search?
__________________
arran3D

arran3D blog
arran is offline   Reply With Quote
Old 28-10-2006, 05:19 AM   #3
richtann
Registered User
 
Join Date: Mar 2004
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

thanks for the suggestion, i have'nt tried the paint select tool.

I've searched in loads of places for info on backface culling, but everything i find just explains how to turn it on and that it makes the backfaces invisible.

Maybe the problem is that in a model like a head, all the faces face outwards, so can still be selected even with backface culling enabled?

I
richtann is offline   Reply With Quote
Old 28-10-2006, 06:21 AM   #4
arran
Registered User
 
arran's Avatar
 
Join Date: Dec 2005
Location: Brooklyn, NY
Posts: 3,708
Thanks: 0
Thanked 9 Times in 9 Posts
Default

yeah, i think you are right. I think it might have something to do with the direction of the normals (under the edit polygons menu). Maybe you can turn on backface culling and then select the faces at the back and reverse their normals. Not sure if that is right though - I have been scratching my head trying to remember how it's done.

To be honest I think using the Paint Selection tool would be an easier solution. I've used it a few times and it's a great way of selecting components.
__________________
arran3D

arran3D blog
arran is offline   Reply With Quote
Old 28-10-2006, 07:18 AM   #5
Vurt
Registered User
 
Join Date: Aug 2006
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Default

i think you're right, cheers


i had a play with he paint selection tool ands, as you say, it's just the job

cheers fella
Vurt is offline   Reply With Quote
Old 28-10-2006, 07:34 AM   #6
arran
Registered User
 
arran's Avatar
 
Join Date: Dec 2005
Location: Brooklyn, NY
Posts: 3,708
Thanks: 0
Thanked 9 Times in 9 Posts
Default

no problem mate.
__________________
arran3D

arran3D blog
arran is offline   Reply With Quote
Old 31-10-2006, 11:40 AM   #7
parka
Registered User
 
parka's Avatar
 
Join Date: Aug 2005
Posts: 102
Thanks: 0
Thanked 4 Times in 4 Posts
Default

Had this problem before.

Go to menu bar:
Display -> Component Display -> Backfaces.

The above will turn backface culling on and all the invisible components at the back will not be selectable.

Do let us know the solution if you solve it.
parka is offline   Reply With Quote
New Thread

« Previous Thread | Next Thread »

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem solving many dynamic objects in a pile? rohiniduggal Dynamics & Special Effects 3 14-01-2011 06:26 PM
apache environment problem andrew_sorensen Simply Maya Tutorials 4 08-12-2010 02:48 PM
Strange Problem - Unable to change attributes for multiple objects anthonysw3 Technical Issues 4 04-12-2010 10:56 PM

1 Month

$34

Month-to-month billing
$34/month
Unlimited access to all videos
Project files to download
Easy to cancel at anytime
 
 

3 months

$87

Billing every 3 months
$29/month
Unlimited access to all videos
Project files to download
Easy to cancel at anytime
Save $5 per month or $15 in total compared to monthly billing with this package.

12 months

$288

Billing every 12 months
$24/month
Unlimited access to all videos
Project files to download
Easy to cancel at anytime
Save $10 per month or $120 in total compared to monthly billing with this package.

Your plan will automatically renew. You can cancel at any time via your PayPal account to avoid being charged again.

You can view the FAQ on our video plans here. You can contact us directly here. By clicking one of the buttons above, you agree to our Terms and Privacy Policy.