SimplyMaya Forums

Welcome to the forum, feel free to ask questions here.

Register FAQ Members List Calendar Mark Forums Read

New Thread
 
Thread Tools
Old 12-10-2009, 04:43 AM   #1
dead_goon
Subscriber
 
Join Date: Aug 2009
Location: Melbourne, Australia
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default Applied shader not showing on Model

Hi there,
I just created some lamberts and assigned them to faces on my model, but the shader doesn't show up unless I render.

Is there an option for it to display without having to render?

Running Maya 2010 on OSX.
dead_goon is offline   Reply With Quote
Old 12-10-2009, 06:15 AM   #2
Perfecto
Registered User
 
Perfecto's Avatar
 
Join Date: Mar 2007
Location: TN (USA)
Posts: 1,882
Thanks: 8
Thanked 127 Times in 119 Posts
Default

Can you be more specific? Did you apply a texture to the created lamberts? or did you just create lambert shaders of different colors and the colors are not showing up in the view port?

If you assigned textures and the textures are not showing up, try moving your cursor over the viewport and pressing the number 6 on your keyboard.
__________________
Don't be satisfied with what you can do but rather strive to do the things you can't do!
Exceed Expectations!
Perfecto is offline   Reply With Quote
Old 12-10-2009, 06:57 AM   #3
dead_goon
Subscriber
 
Join Date: Aug 2009
Location: Melbourne, Australia
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Sorry,
I created a lambert, choose its colour, then selected the faces on my model and then assigned the lambert to the faces.

Hope thats a bit clearer.
dead_goon is offline   Reply With Quote
Old 12-10-2009, 06:45 PM   #4
stwert
EduSciVis-er
 
Join Date: Dec 2005
Location: Toronto
Posts: 3,373
Thanks: 74
Thanked 710 Times in 642 Posts
Default

Is this a problem with just face-specific lamberts? I.e. if you applied the lambert to the whole object, does it show up?
And to repeat Perfecto, have you tried pressing 5,6 and/or 7?
stwert is offline   Reply With Quote
Old 12-10-2009, 08:07 PM   #5
halfloaf
Lifetime Member
 
halfloaf's Avatar
 
Join Date: Mar 2008
Location: Bristol, UK.
Posts: 185
Thanks: 3
Thanked 10 Times in 9 Posts
Default

Are you using OS X 10.6? If "yes" then you're out of luck. Updates in 10.6 have broken some of Maya's display operations. I guess all your objects appear grey?

One way to resolve this is to enable "Hardware Rendering". This should show your textures but you'll loose quite a bit of UI speed.

If you can roll back to 10.5.

Jacques
halfloaf is offline   Reply With Quote
Old 13-10-2009, 02:42 AM   #6
dead_goon
Subscriber
 
Join Date: Aug 2009
Location: Melbourne, Australia
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks guys
Halfloaf, you are right unfortunately.

I will try hardware rendering.
dead_goon is offline   Reply With Quote
New Thread

« Previous Thread | Next Thread »

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Model Errors Urgent advice!! sreynoso Maya Basics & Newbie Lounge 11 23-10-2014 11:39 AM
Dog Model Vox520 Modeling 7 10-12-2010 09:28 AM

1 Month

$34

Month-to-month billing
$34/month
Unlimited access to all videos
Project files to download
Easy to cancel at anytime
 
 

3 months

$87

Billing every 3 months
$29/month
Unlimited access to all videos
Project files to download
Easy to cancel at anytime
Save $5 per month or $15 in total compared to monthly billing with this package.

12 months

$288

Billing every 12 months
$24/month
Unlimited access to all videos
Project files to download
Easy to cancel at anytime
Save $10 per month or $120 in total compared to monthly billing with this package.

Your plan will automatically renew. You can cancel at any time via your PayPal account to avoid being charged again.

You can view the FAQ on our video plans here. You can contact us directly here. By clicking one of the buttons above, you agree to our Terms and Privacy Policy.