SimplyMaya Forums

Welcome to the forum, feel free to ask questions here.

Home / forum / Modeling / Modeling / Bug with extrude face
Register FAQ Members List Calendar Mark Forums Read

New Thread
 
Thread Tools
Old 07-01-2010, 12:46 PM   #1
Mattrumble
Subscriber
 
Mattrumble's Avatar
 
Join Date: Jan 2010
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default Bug with extrude face

Hello,

Me again! I made two simple CV's, lofted, converted to polys then done a face extrude but im getting very odd shading as you can see, any ideas why?
Attached Thumbnails
Click image for larger version

Name:	screen shot 2010-01-07 at 13.53.44.png
Views:	80
Size:	48.3 KB
ID:	43500  
Mattrumble is offline   Reply With Quote
Old 07-01-2010, 06:57 PM   #2
ctbram
Moderator
 
ctbram's Avatar
 
Join Date: Jan 2004
Location: Michigan, USA
Posts: 2,996
Thanks: 42
Thanked 582 Times in 532 Posts
Default

I have seen this a lot. When I see it, I find the usual culprit is multiple shape nodes. If you go into hypergraph and expand all the nodes you will likely see multiple shape nodes.

I find there are several ways to correct this. Delete history, delete one of the extra node from the hyper graph, this often caused the part to lose its shader node input and the remaining piece disappears. Simply reattaching a shader fixes this.

As I recall exporting and importing also fixes the addition shape nodes. I am not sure what causes it or what the correct way to prevent or fix it is. I recall seeing it mentioned in a tutorial once and the author explained it. I believe the cause and fix had something to do with normals.

That is the best I can recall as it has been a long time since I last saw this problem.
__________________
"If I have seen further it is by standing on the shoulders of giants." Sir Isaac Newton, 1675
ctbram is offline   Reply With Quote
Old 10-01-2010, 05:36 PM   #3
NextDesign
Technical Director
 
NextDesign's Avatar
 
Join Date: Feb 2004
Posts: 2,988
Thanks: 33
Thanked 532 Times in 471 Posts
Default

Under polygons, there is a tool menu. There should be one called "keep faces together". Make sure this is checked.
__________________
Imagination is more important than knowledge.
NextDesign is offline   Reply With Quote
Old 11-01-2010, 12:15 AM   #4
ctbram
Moderator
 
ctbram's Avatar
 
Join Date: Jan 2004
Location: Michigan, USA
Posts: 2,996
Thanks: 42
Thanked 582 Times in 532 Posts
Default

Yeah, good point. I could not tell from the image if you were getting separated faces. Make sure keep faces together is checked is excellent advice. (smile)
__________________
"If I have seen further it is by standing on the shoulders of giants." Sir Isaac Newton, 1675
ctbram is offline   Reply With Quote
New Thread

« Previous Thread | Next Thread »

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Extrude Manipulator does not appear Celebrus Technical Issues 11 15-10-2013 08:37 PM

1 Month

$34

Month-to-month billing
$34/month
Unlimited access to all videos
Project files to download
Easy to cancel at anytime
 
 

3 months

$87

Billing every 3 months
$29/month
Unlimited access to all videos
Project files to download
Easy to cancel at anytime
Save $5 per month or $15 in total compared to monthly billing with this package.

12 months

$288

Billing every 12 months
$24/month
Unlimited access to all videos
Project files to download
Easy to cancel at anytime
Save $10 per month or $120 in total compared to monthly billing with this package.

Your plan will automatically renew. You can cancel at any time via your PayPal account to avoid being charged again.

You can view the FAQ on our video plans here. You can contact us directly here. By clicking one of the buttons above, you agree to our Terms and Privacy Policy.