SimplyMaya Forums

Welcome to the forum, feel free to ask questions here.

Home / forum / Lighting & Rendering, Dynamics & Effects, Texturing / Maya Materials & Textures / HELP!!! UV's move when character is animated!
Register FAQ Members List Calendar Mark Forums Read

New Thread
 
Thread Tools
Old 09-11-2003, 11:39 PM   #1
3dgurl
Subscriber
 
3dgurl's Avatar
 
Join Date: Aug 2003
Location: California
Posts: 164
Thanks: 0
Thanked 3 Times in 3 Posts
Exclamation HELP!!! UV's move when character is animated!

OK I have NEVER seen this and I have NO clue what my co-worker did but when the charatcer I'm working on is put into his pose frame all the uvs move into that pose and completely go whack O_O.

here's a screenie of what happens... anyone know how to fix this PLEASE O_O

Attached Thumbnails
Click image for larger version

Name:	help.jpg
Views:	2690
Size:	216.9 KB
ID:	11479  
__________________
3dgurl is offline   Reply With Quote
Old 10-11-2003, 03:49 AM   #2
mtmckinley
The Maya Mountain
 
mtmckinley's Avatar
 
Join Date: Aug 2002
Location: Seattle, WA
Posts: 8,245
Thanks: 1
Thanked 25 Times in 25 Posts
Default

woah, funky. I've not seen that happen when using file textures before, only with procedural. Not sure if the same solution will work, but try creating a texture reference object under the Texture menu in the Rendering module.
__________________
-Mike
www.mtmckinley.net
The Maya Toolbelt
mtmckinley is offline   Reply With Quote
Old 10-11-2003, 10:06 PM   #3
CyberAL
Registered User
 
CyberAL's Avatar
 
Join Date: Oct 2003
Location: San Francisco
Posts: 44
Thanks: 0
Thanked 0 Times in 0 Posts
Default

3dgurl,
This is off topic, but I was curious if those red lines behind the character are curves that you have made to control the rig? Did you do the wing skelly and rig too?
__________________
AL San Miguel
<a href="http://www.smgd.com" target="_blank">www.SMGD.com
CyberAL is offline   Reply With Quote
Old 18-11-2003, 02:06 AM   #4
Pony
Subscriber
 
Pony's Avatar
 
Join Date: Mar 2003
Location: with PonysGirl
Posts: 2,573
Thanks: 0
Thanked 6 Times in 6 Posts
Default

Hay there.. has this problem ever bean fixed ? Really I would like to recreat this. I am in need of makeing some textures deform.
Pony is offline   Reply With Quote
Old 19-11-2003, 11:29 PM   #5
3dgurl
Subscriber
 
3dgurl's Avatar
 
Join Date: Aug 2003
Location: California
Posts: 164
Thanks: 0
Thanked 3 Times in 3 Posts
Default

HAHA well, we figured a "problem" such as this could come in handy for some sort of chrome or liquid type character hehe. I havent been bale to chekc these forums as often as I was able to previously do to my work load increasing and such. I will try your suggestion McKinley =)

In regards to the rigging yes the red curves are part of the rig setup and the wings were rigged using the rigging tut for a bird by Alex Alvarez.

I believe this tut is available on www.highend3d.com under the maya tuts section under rigging/animation.

I will update you guys soon as I can.
__________________
3dgurl is offline   Reply With Quote
Old 21-11-2003, 10:27 PM   #6
3dgurl
Subscriber
 
3dgurl's Avatar
 
Join Date: Aug 2003
Location: California
Posts: 164
Thanks: 0
Thanked 3 Times in 3 Posts
Default

OK texture ref object didnt work >_< any other suggestions?
__________________
3dgurl is offline   Reply With Quote
Old 21-11-2003, 10:44 PM   #7
Pony
Subscriber
 
Pony's Avatar
 
Join Date: Mar 2003
Location: with PonysGirl
Posts: 2,573
Thanks: 0
Thanked 6 Times in 6 Posts
Default

you know it is posible to key frame UV points on the UVmap... this could be your problem. serch and distroy animation curves for the UV's if this is the case.
Pony is offline   Reply With Quote
Old 28-11-2003, 08:47 PM   #8
GrantHortin
Registered User
 
Join Date: Mar 2003
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Your UV set is after the skin cluster in the inputs? If it is, you'll need to move it to the bottom of the inputs.
__________________
If all employers are only looking for people with x-years experience, how the hell do those of us with none get some.
GrantHortin is offline   Reply With Quote
Old 24-12-2015, 12:20 PM   #9
Billogi
Registered User
 
Join Date: Dec 2015
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by GrantHortin View Post
Your UV set is after the skin cluster in the inputs? If it is, you'll need to move it to the bottom of the inputs.
I know this tread is very old now, but it comes up on Google if you are searching for help with this issue.

It does seem to be the UV input being above the Skin Cluster input. I could not move Skin Cluster, so instead I deleted its node and re-binded the skin. That way it is now above my UV inputs and the UVs stay put when animating!

Hope this helps anyone else with this issue!
Billogi is offline   Reply With Quote
New Thread

« Previous Thread | Next Thread »

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Character animation-Finished work maheshsubbiah Finished Work 7 05-12-2010 04:04 AM

1 Month

$34

Month-to-month billing
$34/month
Unlimited access to all videos
Project files to download
Easy to cancel at anytime
 
 

3 months

$87

Billing every 3 months
$29/month
Unlimited access to all videos
Project files to download
Easy to cancel at anytime
Save $5 per month or $15 in total compared to monthly billing with this package.

12 months

$288

Billing every 12 months
$24/month
Unlimited access to all videos
Project files to download
Easy to cancel at anytime
Save $10 per month or $120 in total compared to monthly billing with this package.

Your plan will automatically renew. You can cancel at any time via your PayPal account to avoid being charged again.

You can view the FAQ on our video plans here. You can contact us directly here. By clicking one of the buttons above, you agree to our Terms and Privacy Policy.