SimplyMaya Forums

Welcome to the forum, feel free to ask questions here.

Home / forum / Lounges / Maya Basics & Newbie Lounge / trangles >>> quads...
Register FAQ Members List Calendar Mark Forums Read

New Thread
 
Thread Tools
Old 23-05-2009, 05:24 AM   #1
iamcreasy
Registered User
 
iamcreasy's Avatar
 
Join Date: Jun 2008
Location: Dhaka, Bangladesh
Posts: 168
Thanks: 6
Thanked 8 Times in 8 Posts
Default trangles >>> quads...

I have a obj model.Now i need to import it in maya and add detail and to create normal map.

But the thing this model is created in max and when i open it's obj format in maya then the model is triangulated.So the model looks very messy.When i try to add bevel the edges then i get unexpected result.

SO, i wnt to convert this mode's triangular formation to quads.I have tried the Mesh > quadrungulate.It does not work.But i need quads for smooth and better workflow.

The model is attached.So wht can i do to have the model in quads formation????

One more thing, if there is anyway to have the object directly in quads frm 3ds max.Like using the fbx file format.I tried it in blender but the triangles remains.So any specific option or file format that can preserve the model in quad???
Attached Files
File Type: mb m16 magazine.mb (89.7 KB, 52 views)
iamcreasy is offline   Reply With Quote
Old 23-05-2009, 05:51 AM   #2
harry98941
Registered User
 
harry98941's Avatar
 
Join Date: Dec 2007
Location: bombay
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Layout the Uvs For the Magazine in Max And Then Export the Obj to Maya . try it................
__________________
maya
harry98941 is offline   Reply With Quote
Old 23-05-2009, 07:08 AM   #3
iamcreasy
Registered User
 
iamcreasy's Avatar
 
Join Date: Jun 2008
Location: Dhaka, Bangladesh
Posts: 168
Thanks: 6
Thanked 8 Times in 8 Posts
Default

hmm...when converting to FBX(frm max) i turned off the "Split per-vertex Normals".

Then when i imported the fbx to maya.It was still triangle.But now when i Mesh > quadrangulated the object most of it turned into quad!!!But still not all of them(file attached).

Can anyone give my any explanation? or any better pipeline to do this?

Cause there is lots of triangles still needed to be manually converted to quads!...quadrangulate is not working more then once.What can i do??

in the file.zip...both max and quad converted mb file is attached!

EVEN i tried DXF conversion.But it shows me the same result.Some of the model still remains in tries.
Attached Files
File Type: zip files.zip (19.2 KB, 34 views)

Last edited by iamcreasy : 23-05-2009 at 07:13 AM.
iamcreasy is offline   Reply With Quote
Old 23-05-2009, 09:32 AM   #4
mastone
Maniacal boy king of Babylon
 
mastone's Avatar
 
Join Date: Aug 2005
Location: the netherlands
Posts: 1,605
Thanks: 1
Thanked 59 Times in 58 Posts
Default

The model itself probably has bad topology, (NGons which most of the time result in a quad and a triangle) if i have time i will take a look at your model
mastone is offline   Reply With Quote
Old 23-05-2009, 10:11 AM   #5
ColdWave
Registered User
 
ColdWave's Avatar
 
Join Date: Sep 2006
Location: Bulgaria, Vidin
Posts: 1,309
Thanks: 1
Thanked 19 Times in 19 Posts
Default

Here is your model quadrated. I fix some edges now the loops seems to be fixed If i missed something i'm sorry :p


pipeline : I've open the 1st model you attach.
The problem was that when you export you set to export triangulated mesh, then i simply go into maya and select the object go into the mesh menu and hit convert to quads ( i think that was the name not sure ). After that i cleaned some of the edges and here you go
Attached Files
File Type: mb fixed m_16.mb (96.0 KB, 29 views)
__________________
Art Director
www.sevenbullsgames.com
ColdWave is offline   Reply With Quote
Old 24-05-2009, 09:00 PM   #6
iamcreasy
Registered User
 
iamcreasy's Avatar
 
Join Date: Jun 2008
Location: Dhaka, Bangladesh
Posts: 168
Thanks: 6
Thanked 8 Times in 8 Posts
Default

If u have opened the first MB file attached to the first post then the mesh>quad were not suppose to work!

BUT I HAVE FOUND A WAY TO MAKE IT WORK VERY
EFFICIENTLY!

switching off the "Split per-vertex Normals" while exporting to FBX.Then after exporting maya u have to CLEANUP the model(i did it with the default settings).Then after deleting history i hit the mesh>quad.............I WORKED AS I WANTED!!

as mastone said some weird part remains where n-gons is present.But before the cleanup and deleting history the actuals quads(in MAX) were not successfully converted to quads is maya.

u can have a look of the model attached.(this was done without any manual effort.Where only four corners requires modification.Because they were 6 side in MAX).All the other were perfectly converted to QUADS!
Attached Files
File Type: mb temp.mb (77.8 KB, 27 views)
iamcreasy is offline   Reply With Quote
New Thread

« Previous Thread | Next Thread »

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off

1 Month

$34

Month-to-month billing
$34/month
Unlimited access to all videos
Project files to download
Easy to cancel at anytime
 
 

3 months

$87

Billing every 3 months
$29/month
Unlimited access to all videos
Project files to download
Easy to cancel at anytime
Save $5 per month or $15 in total compared to monthly billing with this package.

12 months

$288

Billing every 12 months
$24/month
Unlimited access to all videos
Project files to download
Easy to cancel at anytime
Save $10 per month or $120 in total compared to monthly billing with this package.

Your plan will automatically renew. You can cancel at any time via your PayPal account to avoid being charged again.

You can view the FAQ on our video plans here. You can contact us directly here. By clicking one of the buttons above, you agree to our Terms and Privacy Policy.