Maya Training

Introduction to Hard Surface Modeling

Maya Training

Interiors and Furniture Vol 1 & 2 - Modeling & Cloth

Maya Training

Shading, Lighting and Rendering the Bedroom in MR

Maya Training

Robot volume one - Modeling with animation in mind

Maya Training

Spach-Alspaugh House the complete courseware

Maya Training

Burt The Cartoon Dinosaur Vol 01 - Modeling

New Maya Training

Robot Volume 02 - Hybrid Rigging
You are here > Home > SimplyMaya Community Forums
Loading

Welcome to Simply Maya

Please Sign in or Sign up for an account

Member Login

Lost your password?

Not a member yet? Sign Up!

Old 04-03-2004, 05:44 AM   #1
Brian820
Registered User
 
Join Date: Jul 2003
Location: Bay Area, CA
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Default Particle Overlap - Omni Emitter not Random?

Good evening,

I'm working on my thesis on Generating Starfields in 3D and have run into a bit of a problem.

Following suggestions by Tolerate and Mr. McKinley, I've created a Starfield using particles. Specifically, this is done by placing an Omni emitter at the origin, setting speed to 0, minimum distance to 600, maximum distance to 900, and then letting the emitter fire away until I have the desired density of stars.

From there, I wanted to add some variation to my stars. Not being too confident with per-particle attributes, I figured the easiest way would be to create a couple more emitters with similar settings and have these emitters fire different particles.

My current set up has three Omni emitters all at the origin:
one for bright yellow stars
one for medium bluish stars
and one for dimmer greyish stars.

Ideally, this would randomly fill the sky with random placements of these three types of particles.

The problem is, all three of my Omni emitters appear to be firing at the exact same locations in space! When all three emitters create a particle at the same spot, the large yellow ones are always seen (being the largest) and the blue and dim ones are unable to be seen, always encapsulated/blocked by the yellow ones.

To prove that this is the case, I put the three different particle types in three layers. If you view them independently, you can see that particles from all three emitters are being placed in the same locations.

How can I fix this?

I tried rotating the emitters, but this made no change.

Any ideas?


Also, if MTMcKinley, Tolerate, Oculus, or NitroLiq happen to view this post - I'd love to give you guys credit once my thesis is complete. If you're willing to give me a little personal information and would like the credit you most definitely deserve, send me a message here or an email to bmrodrig@calpoly.edu . Your full name, and then the company and/or college you most strongly affiliate with would be great.


Thanks in advance,

Brian
Brian820 is offline   Reply With Quote
Old 04-03-2004, 08:35 AM   #2
kbrown
Moderator
 
kbrown's Avatar
 
Join Date: Sep 2002
Location: London, UK
Posts: 3,198
Thanks: 0
Thanked 8 Times in 8 Posts
Default

You could try connecting turbulence fields to your particles... that should mix up your particles
__________________
Kari
- My Website
- My IMDB

Do a lot, Fail a lot and Learn a lot!
kbrown is offline   Reply With Quote
Old 04-03-2004, 12:32 PM   #3
Alan
Moderator
 
Alan's Avatar
 
Join Date: Oct 2002
Location: London, UK
Posts: 2,800
Thanks: 0
Thanked 5 Times in 5 Posts
Default

try changing the seed, if you change the seed it should generate completely different results (it's basically a number that maya uses to generate the data, if you alter it you will get differernt results but if you change back to it the results should be exactly the same....well in theory)

Alan
__________________
Technical Director - Framestore

Currently working on: Your Highness

IMDB
Alan is offline   Reply With Quote
Old 01-10-2005, 07:56 PM   #4
Hubbard
Registered User
 
Join Date: May 2004
Location: New York City
Posts: 42
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Totally stupid question, but the the life of me, I can't find the seed parameter in the emitter attributes or the particle attributes.

I see the "general seed" attribute in the lifespan section of the particle shape attributes, but that doesn't change the randomness of my emitters.

I too have three seperate emitters that are emitting at the exactly same rate, thus overlapping each other.

Can someone help. Like I said, I small brain cannot find the "seed" parameter if it is different than the above.

Thanks.....
Hubbard is offline   Reply With Quote
Old 02-10-2005, 07:53 AM   #5
ragecgi
Super Moderator
 
ragecgi's Avatar
 
Join Date: Sep 2002
Location: Minnesota, USA
Posts: 3,709
Thanks: 0
Thanked 13 Times in 12 Posts
Default

Like Pure morning said, Seed is what this is for, but a lazy way would be to Set an initial State offset for 2 of the emitters.

This way, you can fire one emitter, and stop it at, say, frame 10, set its' initial state, then do the same for one more at a different frame, then, rewind and play, and all 3 emitters should be shooting particles all starting from different locations, i.e. locations from emitter center.
__________________
Israel "Izzy" Long
Motion and Title Design for Broadcast-Film-DS
izzylong.com
ragecgi is offline   Reply With Quote

A little bit about who we are
Links you might find useful
Catch up with SimplyMaya
SimplyMaya specialises in Maya tutorials. We offer over 1,000 individual Maya training videos, ranging from basic Maya tutorials through to intermediate Maya tutorials. Our tutorials are created by instructors with industry experience and are designed to get you up and running in Maya quickly without making it seem like hard work.

Copyright © 1999-2015 SimplyMaya - vBulletin® Copyright © 2000-2015, Jelsoft Enterprises Ltd.