Maya Training

Introduction to Hard Surface Modeling

Maya Training

Interiors and Furniture Vol 1 & 2 - Modeling & Cloth

Maya Training

Shading, Lighting and Rendering the Bedroom in MR

Maya Training

Robot volume one - Modeling with animation in mind

Maya Training

Spach-Alspaugh House the complete courseware

Maya Training

Burt The Cartoon Dinosaur Vol 01 - Modeling

New Maya Training

Robot Volume 02 - Hybrid Rigging
You are here > Home > SimplyMaya Community Forums
Loading

Welcome to Simply Maya

Please Sign in or Sign up for an account

Member Login

Lost your password?

Not a member yet? Sign Up!

Old 27-08-2007, 07:56 AM   #1
Phrosting
Registered User
 
Join Date: Oct 2006
Location: Adelaide Australia
Posts: 65
Thanks: 0
Thanked 0 Times in 0 Posts
Default blend shapes

hey guys!

I am currently trying to put my character's head which has blendshapes for facial expressions on it onto my full body rig but wen i skin the head to the rig, bits of the face stretch and deform horribly.

I've searched the forums on this and tried changing the hierarchy in the all inputs but there are still stretching and deform problems

any help greatly appreciated! thanks friends!
Phrosting is offline   Reply With Quote
Old 27-08-2007, 08:34 AM   #2
jali
Subscriber
 
Join Date: Apr 2005
Location: UK
Posts: 537
Thanks: 1
Thanked 13 Times in 13 Posts
Default

hi

have you tried deleting the non deformer history on the object.

just go to EDIT>DELETE BY TYPE> NON DEFORMER HISTORY.

I think it might work
jali is offline   Reply With Quote
Old 27-08-2007, 11:35 PM   #3
Phrosting
Registered User
 
Join Date: Oct 2006
Location: Adelaide Australia
Posts: 65
Thanks: 0
Thanked 0 Times in 0 Posts
Default

hey man

thanks 4 replying. I tried deleting the non deformer history and it makes the blend shapes deform completely incorrectly and the skin still stretches

i think its a painting skin weights issue maybe, because wen i move the arm it streches the face with the blendshapes on it. I tried selecting the face and flooding it with 0 weight and it all goes black but still stretches anyway

Last edited by Phrosting : 27-08-2007 at 11:38 PM.
Phrosting is offline   Reply With Quote
Old 28-08-2007, 09:55 PM   #4
Phrosting
Registered User
 
Join Date: Oct 2006
Location: Adelaide Australia
Posts: 65
Thanks: 0
Thanked 0 Times in 0 Posts
Default

ok i think i fixed it, so for anyone else who runs into ths problem wat i did was parent the face with the blendshapes onto the skull joint after binding the rig. Probably a dodgy way to do it im not sure but it works fine so far
Phrosting is offline   Reply With Quote

A little bit about who we are
Links you might find useful
Catch up with SimplyMaya
SimplyMaya specialises in Maya tutorials. We offer over 1,000 individual Maya training videos, ranging from basic Maya tutorials through to intermediate Maya tutorials. Our tutorials are created by instructors with industry experience and are designed to get you up and running in Maya quickly without making it seem like hard work.

Copyright © 1999-2015 SimplyMaya - vBulletin® Copyright © 2000-2015, Jelsoft Enterprises Ltd.