Complex UV Layout in Maya
Over the last couple of years UV layout in Maya has changed for the better. In this course we're going to be taking a look at some of those changes as we UV map an entire character
# 1 20-04-2004 , 03:14 AM
JedK's Avatar
Registered User
Join Date: Apr 2004
Posts: 11

Help importing a texture onto a blinn... (edit - another question added @ bottom)

Hey,

I know this is probably really easy to do, and I've been shown before; however, I cannot seem to recall how to go about doing it. I have my hypershade window open and create a new blinn... but where do I go from there?

Any help is appreciated.
-Thanks.
user added image


Last edited by JedK; 20-04-2004 at 09:54 PM.
# 2 20-04-2004 , 05:50 AM
mumbojumbo_13's Avatar
Subscriber
Join Date: Oct 2002
Location: The Land Down Under
Posts: 1,047
select the object you want to apply it to
then in the hypershade right click on the newly created blinn and go to apply material to selected objects
.. something on those lines


Thanks for wasting your time reading this line.
# 3 20-04-2004 , 06:55 AM
JedK's Avatar
Registered User
Join Date: Apr 2004
Posts: 11
No, that will apply the blinn to my model. I need to know how to import a texture and create a blinn with it, so that I can 'then' apply it to my model. For example, I have a wood texture that I want to use in a blinn - how do I do it?

Make sense?
user added image

# 4 20-04-2004 , 07:50 AM
NightPhantom's Avatar
Registered User
Join Date: Nov 2003
Location: Florida
Posts: 269
On the left of the hypershade, click where it says "create material" and then chose "create texture". Or if it says "create all nodes" then just scroll down until you find "2D textures".

Now, click once on "file" (which is under 2D textures). This puts and empty file node in your work area. Now while that node is still selected go to the attribute editor and look for "Image Name", then click the folder icon next to that text box and that will open an open file dialog, look for the picture that you want to use as your texture and then click open. You should be able to see the picture in that file node instead of the black square.

Now, if you don't have the blinn node in your work area drag it there so that you'll have both the file node and the blinn node in the work area. Now, with the attribute editor open, select the blinn material and then hold the middle mouse button over the file node and drag it to the color attribute of the blinn material. Your blinn should now be showing the texture instead of a gray sphere.
Apply the material to your textures and you are all set.

Of course this is only one way to do it. But I won't explain other ways because it's late and I'm sure u'll be ablo to figure them out on your one after some meddeling in Maya.


There can not be Good without Evil, so then it must be good to be Evil sometimes.

:tup:
# 5 20-04-2004 , 07:59 AM
JedK's Avatar
Registered User
Join Date: Apr 2004
Posts: 11

Originally posted by NightPhantom
Now, click once on "file" (which is under 2D textures).

Hmm, I do not see anything that says "file." Under 2D textures, all I see are three radio buttons that say the following: normal, as projection, as stencil. Below these radio buttons it just has a bunch of default textures, and that is it.

What am I missing here? I haven't really messed with anything, so I don't think it has anything to do with an option that I accidentally turned off.

Kinda frustrating here... but really appreciate the help.
-Sorry for the inconvenience. ~_~

# 6 20-04-2004 , 08:02 AM
JedK's Avatar
Registered User
Join Date: Apr 2004
Posts: 11
Hmm, scratch that... I was able to find it by right clicking and going to "create -> 2D texture -> file..." as opposed to finding it on the left column.

Thanks a lot for your help.

# 7 20-04-2004 , 08:08 AM
NightPhantom's Avatar
Registered User
Join Date: Nov 2003
Location: Florida
Posts: 269
See the picture.
Also, I forgot to mention that you should leave the radio buttons in the default, Normal.

Attached Images

There can not be Good without Evil, so then it must be good to be Evil sometimes.

:tup:
# 8 20-04-2004 , 08:22 AM
JedK's Avatar
Registered User
Join Date: Apr 2004
Posts: 11
I can't believe I totally skipped over #2. I guess I was expecting something different for File... and not another picture that looked like a texture - that's what I get for skimming over it too quickly.

Thanks again for going out of your way to help me.

# 9 20-04-2004 , 09:53 PM
JedK's Avatar
Registered User
Join Date: Apr 2004
Posts: 11
Hmm, sorry to bring the topic back up, but I have another question regarding this issue.

After I apply my wooden texture to my model, am I supposed to only be able to see it when I render the model? Because as of now, that's how it is - when just looking at it before rendering, it's still silver/gray.

Any input?
-Thanks much.

# 10 21-04-2004 , 02:33 AM
NightPhantom's Avatar
Registered User
Join Date: Nov 2003
Location: Florida
Posts: 269
hit "6" in your keyboard while the mouse cursor is over the 3D view where you want to see it with textures.


There can not be Good without Evil, so then it must be good to be Evil sometimes.

:tup:
Posting Rules Forum Rules
You may not post new threads | You may not post replies | You may not post attachments | You may not edit your posts | BB code is On | Smilies are On | [IMG] code is On | HTML code is Off

Similar Threads