Introduction to Maya - Modeling Fundamentals Vol 2
This course will look in the fundamentals of modeling in Maya with an emphasis on creating good topology. It's aimed at people that have some modeling experience in Maya but are having trouble with complex objects.
# 1 30-06-2008 , 03:38 AM
Registered User
Join Date: May 2008
Posts: 245

polygon smooth render problem. smooth level doesnt show up in render????

hi everyone,

I have 2 problem.

1- I made a model with polygone. I press 3 so I can see it in smooth level 3 , but when I render it. the render show it only smooth level 1 or nothing smooth, I know there is something need to be changed in setting. I forgot totally, need your help,

2- spherical HDRI image. I made a 2 object, and I apply an spherical HDRI image as environment and shines. but I want this effect only for one of the object not for 2 the objects.
so how can I stop the spherical HDRI image effect for second object. where can I turn it off the setting, need help please
thanks

if you know something say something

# 2 30-06-2008 , 04:53 AM
Registered User
Join Date: Mar 2007
Posts: 1,055
Hi,

to answer your first question, pressing 3 is only to preview the mesh in smoothed form (in the viewport). To actually smooth the mesh, you need to apply a smooth node (mesh > smooth).

Not to sure about your second problem - if you don't want the second object to be reflective at all though, you can go to it's material and decrease it's reflectivity attribute to 0.

cheers

gubar

# 3 30-06-2008 , 05:19 AM
Registered User
Join Date: May 2008
Posts: 245
thanks gubai, the first one is fixed, now the second one?????
anyone any idee?

# 4 30-06-2008 , 05:34 AM
bendingiscool's Avatar
Subscriber
Join Date: Jul 2006
Location: London
Posts: 567
Technically when pressing 3 its actually previewing a subdivided proxy rather than a smooth proxy as you will get different results if you smooth it compared to converting to a subD.

For your second question ideally you want to be rendering out in different layers/passes so that things like your HDRI image can be turned on and off layer dependent.

Although I believe gubar's suggestion may also work.

Chris

# 5 30-06-2008 , 05:56 AM
Registered User
Join Date: May 2008
Posts: 245
hi chris, thanks for replay. the problem is I have 2 object.
both of the object has reflectivity, one from hdri image and the other one from lights, but the lights one gets reflictivity from hdri image as well(I dont want this) looks very messy , so I turn the reflictivity in second objects down to 0 (that is what gubar says), but now I dont get reflectivity at all. so I need help guys,

how can I apply HDRI image only to one object?

thanks

# 6 30-06-2008 , 06:09 AM
jsprogg's Avatar
Lifetime Member
Join Date: Feb 2004
Location: Chicago
Posts: 1,712
Bendingiscool has the best idea....

You need to create 2 render layers, one with the single object and your HDRI sphere (if you need the other two relections add them also but have only visible in reflections) and the other render layer with the other objects and if you need the first object in it just for reflection you can turn off it's visibility and have it visible in reflections only.
Save the renders out on the format that allows an Alpha channel and then composite the two renders together in something like Photoshop.




2 x Modeling Challenge Winner
# 7 30-06-2008 , 06:21 AM
Registered User
Join Date: May 2008
Posts: 245
jsprogg. thanks for your idee, its works, but it takes time and bit longer process, 2 weeks ago I was watching one of the digital tutores tutorials. Apply HDRI image to chair and coffee cup. I saw good technique that actually you can apply the HDRI image to different images and some object of your scene, I went through the whole tutorial to find this option. I can't find it. I am sure I heard somewhere, but cant find out which part of the tutorials was., therefore I ask someone if he/she knows about this option without layer rendering and compositing. any more idee guys?

# 8 30-06-2008 , 09:31 AM
Mayaniac's Avatar
As Zbrushiac sounds stupid!
Join Date: Nov 2007
Location: Derby
Posts: 1,241
To get the reflections to appear on one object and not the other, simply select the object that you don't want to receive reflections, and in the attribute editor (ctrl a) under the mentalRay tab. Un-check 'Trace Reflections'.

Heres an example:

Attached Thumbnails

www.stevenegan-cgi.com

"Your weapons are no match for ours! People of Mars, surrender!"
"Um, this isn't Mars. This is Earth."
"Earth? Earth-with-nuclear-weapons Earth?"
"Yes."
[long pause] "Friend!!"
# 9 30-06-2008 , 09:48 AM
Mayaniac's Avatar
As Zbrushiac sounds stupid!
Join Date: Nov 2007
Location: Derby
Posts: 1,241
To have your model smoothed during rendering, simply go to> window> Rendering Editors> Mental Ray> Approximation Editor.

... And create a Subdivision.

Example:

Attached Thumbnails

www.stevenegan-cgi.com

"Your weapons are no match for ours! People of Mars, surrender!"
"Um, this isn't Mars. This is Earth."
"Earth? Earth-with-nuclear-weapons Earth?"
"Yes."
[long pause] "Friend!!"
# 10 30-06-2008 , 10:35 PM
Registered User
Join Date: May 2008
Posts: 245
hey Mayaniac,

thanks so much for your good explanation, all fixed now, that was I am looking for, you are brilliant,
Thanks again and have nice time till next question.

# 11 01-07-2008 , 03:52 AM
Registered User
Join Date: Mar 2007
Posts: 1,055
Glad this is sorted for you now.

Mayaniac, is the effect of this different from just lowering the material's reflective attribute to 0? In either case it would not reflect but would still catch specular highlights from lights?

cheers

gubar

# 12 01-07-2008 , 04:03 AM
Registered User
Join Date: May 2008
Posts: 245
thanks gubar, your opinion is good too, you guys smart and amazing. thanks for your help,

# 13 09-07-2008 , 10:10 PM
NeoStrider's Avatar
Registered User
Join Date: Jun 2004
Location: Cleveland, Ohio (USA)
Posts: 1,541
the difference between the two operations (turn off trace reflectivity versus turning down the reflectivity to zero) is that the first one deals with the object ONLY... you can have several objects with the same material and ONLY that object will not reflect - whereas with the second option, all objects with that material applied won't reflect.

and as you can see in mayaniac's second image, it'll still catch specular highlights since that's a different value that gets altered in the material.


Accept no substitutions.
# 14 09-07-2008 , 10:33 PM
Registered User
Join Date: May 2008
Posts: 245
NeoStrider you are right, when I turn off the reflectivity from second object, I can get reflectivity at all. I applied light on the scene and now I cant get the reflectivity at ll on second object, so what is next, how can we fix that, I notice it today,
here is the question,
I have 2 object 1 with reflectivity from HDRI image only the number 2 object the reflectivity from light or other shaders, so how can I fix this one, 2 object close to each other one with reflectivity from hdri image, and second with light

need more help guys, if you know something say something,

# 15 09-07-2008 , 11:01 PM
NeoStrider's Avatar
Registered User
Join Date: Jun 2004
Location: Cleveland, Ohio (USA)
Posts: 1,541
go back into the object and turn trace reflection back on


Accept no substitutions.
Posting Rules Forum Rules
You may not post new threads | You may not post replies | You may not post attachments | You may not edit your posts | BB code is On | Smilies are On | [IMG] code is On | HTML code is Off

Similar Threads