SimplyMaya Forums

Welcome to the forum, feel free to ask questions here.

Home / forum / Lounges / Technical Issues / Raytracing Problem
Register FAQ Members List Calendar Mark Forums Read

New Thread
 
Thread Tools
Old 18-02-2011, 07:23 AM   #1
Lanza
Registered User
 
Join Date: Feb 2011
Posts: 2
Thanks: 0
Thanked 1 Time in 1 Post
Default Raytracing Problem

I thought it was an issue with final gather, but it's a problem with the raytracing itself. light will pass through "cracks" that aren't there at all and on models that have smoothed normals, and create streaks or blotches of light. I've been playing around wit the normals and think that might be the issue, but I've redone the normals every way I can think of..

here are some screenshots:
http://dl.dropbox.com/u/21092303/ren..._issues/1.jpeg
http://dl.dropbox.com/u/21092303/ren..._issues/2.jpeg
http://dl.dropbox.com/u/21092303/ren..._issues/3.jpeg
http://dl.dropbox.com/u/21092303/ren..._issues/4.jpeg

same thing happens when I export the same models as OBJ (only happens with the sofas) without the normals information even and reimport it into a totally new scene. I'm using directional light.

here's the chair OBJ:
http://dl.dropbox.com/u/21092303/ren...sues/chair.obj

I can't see any hidden faces or double edges. what is going on? I have a good amount of experience with Maya, but I'm stumped by such a simple problem..
Lanza is offline   Reply With Quote
The Following User Says Thank You to Lanza For This Useful Post:
Old 18-02-2011, 11:54 AM   #2
Perfecto
Registered User
 
Perfecto's Avatar
 
Join Date: Mar 2007
Location: TN (USA)
Posts: 1,882
Thanks: 8
Thanked 127 Times in 119 Posts
Default

I'm guessing you've already considered near camera clipping? If I set my near camera clipping too high, I get similar results. Not that that's the issue though.
__________________
Don't be satisfied with what you can do but rather strive to do the things you can't do!
Exceed Expectations!
Perfecto is offline   Reply With Quote
The Following User Says Thank You to Perfecto For This Useful Post:
Old 18-02-2011, 01:59 PM   #3
honestdom
The Nurb Herd
 
honestdom's Avatar
 
Join Date: Oct 2007
Location: London
Posts: 2,381
Thanks: 4
Thanked 298 Times in 288 Posts
Default

i can't even tell what i'm looking at tbh.
honestdom is offline   Reply With Quote
The Following User Says Thank You to honestdom For This Useful Post:
Old 19-02-2011, 01:14 AM   #4
Lanza
Registered User
 
Join Date: Feb 2011
Posts: 2
Thanks: 0
Thanked 1 Time in 1 Post
Default

basically in areas that are supposed to be in complete shadow (such as the curve where the back of the chair and base connect in the third image) there will be a strange sliver or area of light that does not make sense. Same with a similar object in picture 4 where the arm rest connects to the base there is a triangle of light that is supposed to be in shadow.

both objects are fairly simple meshes that only consist of a single mesh and should not have any problems. near clipping isn't the problem.
Lanza is offline   Reply With Quote
Old 23-02-2011, 04:43 PM   #5
BabyDuck
Subscriber
 
BabyDuck's Avatar
 
Join Date: Nov 2002
Location: USA
Posts: 1,170
Thanks: 3
Thanked 12 Times in 12 Posts
Default

could that be just a reflection of something else in the scene? the chair object you attached has a lambert shading group - but the material is of type phong with 0.5 reflectivity ??? but that is me beeing stupid - you probably did that on purpose ....
BabyDuck is offline   Reply With Quote
The Following User Says Thank You to BabyDuck For This Useful Post:
Old 23-02-2011, 07:28 PM   #6
Gen
Moderator
 
Gen's Avatar
 
Join Date: Dec 2006
Location: South FL
Posts: 3,494
Thanks: 16
Thanked 645 Times in 567 Posts
Default

I took a look at the model, I noticed the problem went away when the model is smoothed (which also got rid of those tris in there). Which leaves me to believe it may be caused by the low poly count. You're ending up with some seriously non planar faces and there could be some trouble deciding if they should be illuminated or not. I ditched the phong shader because the highlights and reflections were just getting in the way.
Attached Thumbnails
Click image for larger version

Name:	nonPlanars.png
Views:	114
Size:	223.7 KB
ID:	46139  
__________________
- Genny
__________________
::|| My CG Blog ||::
::|| My Maya FAQ ||::
Gen is offline   Reply With Quote
New Thread

« Previous Thread | Next Thread »

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
animating simple bone rotation problem lost lobe Technical Issues 1 18-02-2011 02:04 AM
problem with smooth bind duyquyen Animation 1 17-02-2011 01:34 PM
Fluid effects Smoke/Fog looks bad, aliasing problem? Bugsby Maya Basics & Newbie Lounge 11 08-02-2011 03:11 PM
Image plane problem nusphere Technical Issues 2 25-01-2011 02:37 AM
Camera rendering problem! Aurorap Lighting & Rendering 2 08-01-2011 09:42 PM

1 Month

$34

Month-to-month billing
$34/month
Unlimited access to all videos
Project files to download
Easy to cancel at anytime
 
 

3 months

$87

Billing every 3 months
$29/month
Unlimited access to all videos
Project files to download
Easy to cancel at anytime
Save $5 per month or $15 in total compared to monthly billing with this package.

12 months

$288

Billing every 12 months
$24/month
Unlimited access to all videos
Project files to download
Easy to cancel at anytime
Save $10 per month or $120 in total compared to monthly billing with this package.

Your plan will automatically renew. You can cancel at any time via your PayPal account to avoid being charged again.

You can view the FAQ on our video plans here. You can contact us directly here. By clicking one of the buttons above, you agree to our Terms and Privacy Policy.