Introduction to Maya - Modeling Fundamentals Vol 2
This course will look in the fundamentals of modeling in Maya with an emphasis on creating good topology. It's aimed at people that have some modeling experience in Maya but are having trouble with complex objects.
# 1 23-07-2013 , 07:09 PM
Registered User
Join Date: Jul 2013
Posts: 15

UV Mapping problems

Hey everyone. I'm having some major difficulties with UV mapping at the moment. I'm attempting to apply a new Lambert with an imported .png to a part of my model. The image appears on the applied object, but not in the UV Texture Editor. I performed a UV Snapshot and created the .png file in Photoshop, but everything is out of place, and I cannot make any adjustments to my UVs.

This link is a picture of the problem: https://imgur.com/vE4MtLp

As you can see, the image appears on the mesh, but the imported image is dark gray in the Editor. I'm curious to know if anyone else is having this problem, and if so, what did you do to resolve this? Also the "Display Image" is on.

# 2 23-07-2013 , 07:26 PM
mickhah's Avatar
Registered User
Join Date: Apr 2011
Location: Dortmund, Germany
Posts: 229
your texture is repeated. you have to adjust the "repeat uv" attribute in the "place2dtexture" node of your texture.

# 3 23-07-2013 , 08:53 PM
Registered User
Join Date: Jul 2013
Posts: 15
I played around with the values, but nothing happens. I also think you may have misread my question. I can't view my imported image in the UV Texture Editor. I have the default map1, which is being displayed on the car hood. However, the planar map UV Set I created stays gray in the editor.

# 4 24-07-2013 , 05:05 AM
bullet1968's Avatar
Lifetime Member
Join Date: Feb 2010
Location: Australia
Posts: 4,255
Is that one object? as mickhah said the texture appears to be repeated on each individual face. I would delete the lambert...select the object again and put the .png into the colour slot in the new lambert...something you have done is odd there. If you have done it as per normal you shouldnt have to fool with the UV/place 2D settings. I think there is also a scale ratio/normalistaion tab in the imported texture file node, set that to none or off.

Cheers bullet


bullet1968

"A Darkness at Sethanon", a book I aspire to model some of the charcters and scenes
# 5 24-07-2013 , 02:29 PM
Registered User
Join Date: Jul 2013
Posts: 15
I'm not sure why everything keeps repeating. I attempted to create a new lambert and UV set for the hood by using automatic mapping with a bounding box. For some reason it worked, but now it won't work on the other objects in the scene.

I have 2 UV Sets per object. One of them is the default "map1", which I can't erase, and the other is the created UV Set. I do a snapshot with the new UV Set, apply the lambert file, and then my lambert is automatically applied to map1. It's odd because it won't apply to the created UV Set, and I can't switch them around.

Also, Maya applied my new UV Set for the hood to "map1", but it won't do that to the others. I put some images together to show you.

Default "map1" UV Layout:
https://imgur.com/ngqOEB8&Ownb43q&lAjOuvF#0

Default "map1" UV Layout:
https://imgur.com/ngqOEB8&Ownb43q&lAjOuvF#1

Created "LFBumper" UV Layout:
https://imgur.com/ngqOEB8&Ownb43q&lAjOuvF#2

The UV layout for "map1" on the hood automatically changed to the created UV set. The second picture shows the lambert image for the bumper. The third picture shows the created layout, but the lambert image won't appear.

# 6 24-07-2013 , 03:15 PM
Registered User
Join Date: Jul 2013
Posts: 15
Thanks guys, I just figured it out. It wasn't through the methods you described, but I'll explain what I did in case someone else has this issue.

Window -> Relationship Editor -> UV Linking -> UV Centric

This allowed me to reassign different Layouts to different Lambert files. Happy modeling. user added image

# 7 25-07-2013 , 02:55 AM
bullet1968's Avatar
Lifetime Member
Join Date: Feb 2010
Location: Australia
Posts: 4,255
Ahhh at least you got it user added image I have never had that issue.

cheers bullet


bullet1968

"A Darkness at Sethanon", a book I aspire to model some of the charcters and scenes
Posting Rules Forum Rules
You may not post new threads | You may not post replies | You may not post attachments | You may not edit your posts | BB code is On | Smilies are On | [IMG] code is On | HTML code is Off

Similar Threads