Complex UV Layout in Maya
Over the last couple of years UV layout in Maya has changed for the better. In this course we're going to be taking a look at some of those changes as we UV map an entire character
# 1 04-05-2015 , 12:39 PM
Registered User
Join Date: May 2015
Posts: 6

MEL Script help (Beginner)

Hi guys, This is my first post here on this forum. I am very excited about learing Maya and I hope there people here who can help me along the way.

Right now I study Online courses about rigging and they did use a MEL script that I thing chould be useful. But when I copy the exact MEL script over to the Script Editor in Maya (2014), I get an error.

Can some kind soul help me with this error? What did I do wrong? I double and triple checked the script they use in the Online Coures, and I can't for my life find any difference.

Thanks in advance.

The script:
Code:
//cOBJ - center object between selection...
pointConstraint;
//Find the object to center (last selection)...
string $grabEnd[] = `sl -sl -tl l;
//Remove its point constraint...
string $findPtCns[] = `listRelatives -type pointConstraint $grabEnd`;
select $findPtCns; doDelete;
Error from the console:
Code:
//cOBJ - center object between selection...
pointConstraint;
//Find the object to center (last selection)...
string $grabEnd[] = `sl -sl -tl l;
//Remove its point constraint...
string $findPtCns[] = `listRelatives -type pointConstraint $grabEnd`;
select $findPtCns; doDelete;
// Error: string $grabEnd[] = `sl -sl -tl l; // 
// Error: Line 4.34: Syntax error //

# 2 04-05-2015 , 02:49 PM
David's Avatar
SM Tea Boy
Join Date: Apr 2002
Location: Prague
Posts: 3,224
At a quick glance it looks like you're missing a ` at the end of this line

string $grabEnd[] = `sl -sl -tl l;

before the ;

Don't have maya open atm but that looks like it.
Welcome to SM
Dave


From a readers' Q and A column in TV GUIDE: "If we get involved in a nuclear war, would the electromagnetic pulses from exploding bombs damage my videotapes?"
# 3 04-05-2015 , 03:33 PM
Registered User
Join Date: May 2015
Posts: 6

At a quick glance it looks like you're missing a ` at the end of this line

string $grabEnd[] = `sl -sl -tl l;

before the ;

Don't have maya open atm but that looks like it.
Welcome to SM
Dave

Yes you're right. Thank you very much!

//KoadRilL

# 4 04-05-2015 , 08:32 PM
Gen's Avatar
Super Moderator
Join Date: Dec 2006
Location: South FL
Posts: 3,518
That's the first thing I noticed. Maybe you could give the people offering this course a heads up as I'm sure there are other people ripping their hair out about this haha.


- Genny
__________________
::|| My CG Blog ||::
::|| My Maya FAQ ||::
Posting Rules Forum Rules
You may not post new threads | You may not post replies | You may not post attachments | You may not edit your posts | BB code is On | Smilies are On | [IMG] code is On | HTML code is Off

Similar Threads