Complex UV Layout in Maya
Over the last couple of years UV layout in Maya has changed for the better. In this course we're going to be taking a look at some of those changes as we UV map an entire character
# 1 22-10-2004 , 11:48 PM
slickrenderer's Avatar
Subscriber
Join Date: Jan 2003
Location: Zurich/London
Posts: 663

Motion path is driving me nuts!!! Take a look please

Ok I have a simple path. I have attached a triangular object to it. When you scrubb the timeline the triangular object moves around on the path.
My problem is that the object changes direction while rotating around the path.

I have tried all combinations under "Motion path" attribute...stuff like - world up type, inverse up, inverse front, front axis etc etc

It's driving me NUTS! What am I doing wrong?

Here is a sample file. Take a look. I have duplicated and manually placed the object on the path to demonstrate how I want the object to move around when the timeline gets scrubbed.


grrr

Here another one with the problem.
grrr2

Check out frame 62 and 90 !!!!

Thanks for the help.


grrrr

Last edited by slickrenderer; 24-10-2004 at 05:49 PM.
# 2 23-10-2004 , 12:25 AM
NitroLiq's Avatar
Moderator
Join Date: Nov 2002
Location: New York
Posts: 2,133
Almost sounds like a problem with the pivot of the object itself. I'd take a look but alas I still use Maya 5 and can't open your file.


"Terminat Bora Diem, Terminal Auctor opus."
# 3 24-10-2004 , 09:15 AM
slickrenderer's Avatar
Subscriber
Join Date: Jan 2003
Location: Zurich/London
Posts: 663
Anyone else???


grrrr
# 4 24-10-2004 , 03:14 PM
NitroLiq's Avatar
Moderator
Join Date: Nov 2002
Location: New York
Posts: 2,133
Did you check the object's pivot to see if it's local or global?


"Terminat Bora Diem, Terminal Auctor opus."
# 5 24-10-2004 , 04:04 PM
slickrenderer's Avatar
Subscriber
Join Date: Jan 2003
Location: Zurich/London
Posts: 663
Pivot point is in the middle of the object.

I think the problem is more in this direction = ***.
The thing is I changed every option and I always end up with something not maintaining it's position. I mean the object moves along the path but the orientation always changes at one or the other point.

If I make a completely new one then everything works fine.
I am just trying to get to the bottom of this problem as it happened to me in the past as well and drove me nuts.

Maybe the path is haunted :-)

***Taken form help file-

"If the path curve is a curve in world space, then the normal of the curve is the direction that points to the center of curvature of the curve at any point on the curve. This is best illustrated by the arrows in the diagram below, which indicate the normal to the curve at various points:

Note that the normal to a curve will flip 180 degrees when the curve changes from a convex to concave (or vice versa) shape. This makes the Normal option for the Up Direction not very desirable when using a world-space curve in your path animation."


grrrr

Last edited by slickrenderer; 24-10-2004 at 04:07 PM.
# 6 24-10-2004 , 05:50 PM
slickrenderer's Avatar
Subscriber
Join Date: Jan 2003
Location: Zurich/London
Posts: 663
Here is another one with the problem.

grrr2

Check out frame 62 and 90 !!!! Why does it do that? I have played with all combinations in the attribute editor!!!


grrrr
# 7 24-10-2004 , 07:22 PM
NitroLiq's Avatar
Moderator
Join Date: Nov 2002
Location: New York
Posts: 2,133
Well, I guess you're going to have to wait for someone that has maya 6 or you could try and post this in the maya forum at cgtalk as well.


"Terminat Bora Diem, Terminal Auctor opus."
# 8 24-10-2004 , 07:47 PM
slickrenderer's Avatar
Subscriber
Join Date: Jan 2003
Location: Zurich/London
Posts: 663
No problem ;-)


grrrr
Posting Rules Forum Rules
You may not post new threads | You may not post replies | You may not post attachments | You may not edit your posts | BB code is On | Smilies are On | [IMG] code is On | HTML code is Off

Similar Threads